2

So I connect my new external USB HDD to my PC and it's detected and configured automatically by Windows. (It's running Windows 10 Pro.) It gets assigned a drive letter and since it is pre-formatted I can start using it immediately.

But once I reboot my PC, the USB HDD causes my PC to hang at the POST screen. If I disconnect the HDD the PC stays frozen at the POST screen. If I reset the PC, and leave the HDD disconnected, it no longer hangs at the POST screen. Once Windows is loaded and I connect the HDD again, it is recognized, mounted and I can start using it.

If I leave the HDD disconnected, reboot, enter BIOS setup, and then connect the HDD, it causes the BIOS setup program to freeze. At that point, it does not help disconnecting it. It stays frozen. I can't make any selections with the arrow keys, everything is frozen. Not even the Ctrl+Alt+Del helps reset the PC. I have to press the reset button.

What is causing this? What can I do about it?

2

This may happen if your PC is using the old BIOS system. This problem is usually not present on computers that use a modern UEFI system.

Solution #1

What you can to do in this case is enter your BIOS setup program and disable the legacy support for UMS (USB Mass Storage) devices. This option may or may not be available in your BIOS setup program. It may also be labeled differently in different BIOS setup programs.

To disable this option on an Award BIOS motherboard, do the following.

  1. Boot up or reboot your PC.
  2. Press DEL to enter BIOS setup.
  3. Go to Advanced Peripherals.
  4. Select USB Storage Function.
  5. Change its value to Disabled.
  6. Press ESC.
  7. Press F10 to save changes and exit.
  8. Confirm with Enter.

Your PC should now thank you and boot up normally without hanging itself with the tethered USB HDD around its neck.

Note! Disabling the USB Storage Function will prevent your PC from booting from USB devices. If you ever need to boot from USB device, for example to install an operating system, be sure to enable this function before you trying booting off of the USB device.

I have tested and confirmed this procedure using Seagate Backup Plus Desktop HDD (4 TB, USB 3.0) and Award BIOS 6.00PG on a Gigabyte GA-X38-DQ6 motherboard.

I have also tested a second HDD of the same brand and model on a Gigabyte GA-MA with the same results and findings.


Solution #2

Another thing you can do is try connecting the HDD to a different USB port.

  1. Power off PC.
  2. Disconnect all USB devices including the keyboard and mouse.
  3. Connect the HDD to USB port 0.
  4. Power on PC and check if it hangs.
  5. If it hangs, power off PC.
  6. Connect the HDD to USB port 1.
  7. Power on PC and check if it hangs.
  8. Repeat until you find a port at which the PC no longer hangs.

Note! This solution is theoretical and untested.

The idea behind this is that some USB port(s) may be used by a different USB controller. A different host USB controller may have better compatibility with the USB controller of the external HDD. You can also check your PC or motherboard manual to see what chip controls what USB port. You may have to enable it inside BIOS setup first before you can use it.


Cause

The exact cause of this odd behavior is unknown to me. But it seems that it has to do with the inner workings of BIOS systems. Old tech and new tech don't mix all too well. While the HDD is backwards compatible with USB 2.0, it may not be compatible with USB 1.1 hosts which is what the BIOS may be enforcing for UMS class devices when the mentioned option is set to Enabled. It may be a compatibility issue between certain USB controllers of the PCs and the drives.

Whatever the cause may be, I hope this answer proves helpful to other users who are using old BIOS systems.

  • I didn't see the comment. What was the comment? Now that you have removed the comment, this comment is pointless as well. – Samir Sep 23 '16 at 8:21
0

What I did was disconnect the USB from the USB Hub that I have connected to my laptop cooling pad, and computer mouse; then I connected the hard drive to the right side of my Acer V3 laptop computer operating on Microsoft Windows 10, and it worked! For now, anyway. ? I have had this problem several times! Won't Microsoft ever solve it? The only solution that I've found, in the recent past, is to simply turn off the external hard drive that I use for backing up most of my data, and pictures. My laptop computer was purchased in 2013, ran on Windows 8, I then upgraded to version 8.1, a better operating system! Then recently, late last year, in 2016, to Windows 10; which is an improvement. Therefore, why can't Microsoft rectify these compatibility problems is beyond me.

  • 1
    While we appreciate this post, it does not answer the specific question of what is causing this and what can be done about it. – SDsolar Jun 19 '17 at 6:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.