0

I bought a 2m Belkin Cat5e crossover cable as a solution to transferring large amounts of files between my desktop PC and my Dell Latitude D530 as quickly as possible. Both are running Windows 7, but I've had no luck setting them up so far. The computers seem to recognise the cable well enough straight away, but it shows as an unknown Local Area Connection with "no internet access".

Based on at least 10 different sources on the net, this is what I've been following to try and get it to work:

  1. Set the IP address of the first computer to 192.168.0.1, and that of the second computer to 192.168.0.2
  2. Set the subnet masks of both computers to 255.255.255.0
  3. Leave the Default Gateway field blank so Windows assigns it automatically
  4. Make sure both computers have different names but are on the same workgroup

Doing all of this resulted in a connection between the two machines, even if I still wasn't able to disable the authentication when connecting to one computer from the other. I then tried transferring my files, and it gave me a rate of 11MB/s, a lot slower than the 100MB/s I bought the cable for.

Going back to the drawing board, I found a few sources that mentioned manually entering DNS options instead of allowing W7 to assign them automatically. These sites said to set the default gateway of each computer to be the same as the IP address of the other computer. So, so far:

Computer 1:

  • IP Address: 192.168.0.1
  • Subnet Mask 255.255.255.0
  • Default Gateway: 192.168.0.2

Computer 2:

  • IP Address: 192.168.0.2
  • Subnet Mask 255.255.255.0
  • Default Gateway: 192.168.0.1

After doing this, almost instantly Windows 7 recognised the previously-unknown network and gave me the option to consider it Home or Public. I made it a Home network on both computers, and then tried to transfer again, hoping this would have solved the issue. This time, however, I got a speed of 1MB/s.

So, here I am, exasperated and kinda lost. From what I read before I bought the crossover cable, I got the impression it would be a quick and relatively painless way to transfer my files between the two machines, but it's turning out to be a lot more involved, to say the least. It doesn't help that networking isn't really my thing, either. So, I'd really appreciate some help in figuring out what I'm doing wrong and exactly how I can get the 100MB/s+ speeds that crossover cables are advertised at.

Thanks!

  • 3
    Please don't add a default gateway - this is often misrepresented. The default gateway tells the computer how to get to networks that it is not directly connected to - such as the internet. It should be left blank on all interfaces except the one leading to the internet. Also note that 100 mega bits per second is around 11 mega bytes per second. – Paul Sep 23 '16 at 4:16
  • But what about the fact that it's the only way for Windows 7 to recognise it as anything but an unknown network? Will I still be able to connect via the cat5e on an unknown network? And wait, what? You mean I'm getting the speeds I should be getting? 100mbits/s translates into just 11MB/s? – Hashim Sep 23 '16 at 4:38
  • 2
    Network card speeds are defined as bits per second, whereas transfer rates are often measured in bytes per second. There are 8 bits in a byte, which is 12.5MB/s at 100mbits/s. There will always be some overhead, so 11MB/s is a reasonable top. – Paul Sep 23 '16 at 7:12
  • 1
    Having said that, the network cards are probably 1000mbit - gigabit, if they are recent. So you'd expect a top of > 100MB/s if they negotiate gigabit at both ends, see the answer below and comments to make sure. – Paul Sep 23 '16 at 7:15
  • Tested and updated - see comments below. – Hashim Sep 23 '16 at 23:32
0

Since the connection is working, it appears the link speed is not properly getting negotiated. Manually set the link speed to 100Mbps in the properties of each adapter.

  • How would I do that? I can't see an option for speed anywhere in the Properties window of the connection. – Hashim Sep 23 '16 at 4:14
  • its under the advanced tab of the network controller properties. select speed & duplex, set to 1000mbps full – Keltari Sep 23 '16 at 4:16
  • Okay, I've just checked. The network card on the D530 laptop is listed as a "Gigabit Controller", but the max value is 100Mb full. The network card on my desktop - RealTek PCIe FE Family Controller - doesn't seem to be gigabit-capable, but also has a maximum value of 100Mb full. Also, what about the fact that the connection says it has no internet acess, and when pinging between each other there is no response? Is that how it's supposed to work, or could it be something isn't configured right? – Hashim Sep 23 '16 at 22:57
  • Something I'm particularly confused about - in the Sharing tab of the connection's Properties window, is Internet Connection Sharing meant to be checked or not? The guides I've looked at don't mention anything about this, so I did it myself - maybe it being enabled could be affecting something? – Hashim Sep 23 '16 at 22:58
  • 1
    that is correct – Keltari Sep 24 '16 at 0:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.