I installed rEFInd 0.10.3 (latest version on the date) on my MacBook Air late 2015 with macOS Sierra, but I`m getting the following error when trying to boot from an usb disk: "Not found while loading legacy loader"

I have tried creating multiple different live USBs (from Ubuntu 16 and Debian 8 ISOs) using the methods: dd command, putting a iso in the folder, creating a bootable UBS with Rufus(dd and ISO mode) and with YUMI.

Click to see the Error Picture

I've tried a lot before asking: Is there a solution ?


A new version was released ( 0.10.4 ), but although the developer says it works for him, it is still not working for me.

Developer Note:

Note: As of version 10.12 ("Sierra"), Apple has renamed its OS X OS to macOS. I continue to use "OS X" to refer to any version of this OS. I've seen reports of rEFInd not working with macOS 10.12; however, my own experience is that it works fine—with the caveat that the upgrade produces a boot coup, as described on this page of the rEFInd documentation,

2 Answers 2


The error message you're seeing indicates that you're attempting to boot a disk in BIOS/CSM/legacy mode and it's not working. This is a common problem on Macs when booting USB drives, and unfortunately, the causes are many and such problems can crop up on some specific Mac models but not on others, which makes these problems very difficult to debug and fix. Worse, the way that rEFIt (and therefore rEFInd) boots in BIOS mode on Macs is very cryptic, so it's hard for me (I'm rEFInd's maintainer) to support this code. In some cases, holding down Option (or Alt) as you power on the computer will work better than rEFInd for booting a USB drive in BIOS mode, so you might try that.

It's usually better to boot USB media in EFI mode, if at all possible. Unfortunately, some tools don't create EFI-bootable USB drives, so you may need to try several tools before you find one that works. In theory, both Rufus (Windows only) and dd (Linux and OS X) should work, but Rufus has several options that you must pick correctly, and dd can easily be used incorrectly. See here for some more on this subject.

Another alternative, if your Mac has an optical drive, is to create a DVD from the .iso file. Your recent MacBook probably lacks this feature, but an external optical drive might work, and so is worth trying if you have access to one.

  • How would you suggest me creating the bootable USB then? The only thing I have not tried is writing my Linux ISO into my free partition on my mac. Would it even work ? (I do not have an external optical drive. My Mac is a late 2015 Macbook Air)
    – Auyer
    Nov 7, 2016 at 22:29
  • Please see the page to which I linked, which covers the issue in detail: rodsbooks.com/efi-bootloaders/…
    – Rod Smith
    Nov 8, 2016 at 14:35

The problem is Sierra's file system (APFS) which is not accessible to refind (it has no driver for it), thus, refind cannot access Sierra's boot loader and you are left with that error message.

I think a possible solution is to copy Sierra's boot loader (and few additional files, eventually) onto the ESP partition... I tried that... but I could not manage to get it working since I got other error messages.


I believe that while upgrading from 'El Capitan' to 'Sierra' does preserve the pre-existing HFS+ partition, installing a fresh copy of 'Sierra' does not (HFS+ partition is formatted with APFS - but I'm not sure about that since I performed a fresh install only and I ended up with the experimental APFS).


BTW, it seems that Apple will release the final/stable version of APFS by the fall of 2017, when all Apple devices will be forced to use APFS! Moreover, the stable version of APFS will be fully documented and released under the open source licence.


I realized it was my fault, while installing Sierra, to have selected APFS instead of HFS+ for the macOS partition. I discovered that using the gdisk utility in linux; APFS corresponds to partition type AF05 while HFS+ corresponds to AF00. I've done this mistake on two out of four computers and now I can confirm that rEFInd still works on a Sierra Mac as long as you have the macOS partition formatted with HFS+.

  • Should we wait for an update then ?
    – Auyer
    Sep 24, 2016 at 22:09
  • Any new information ?
    – Auyer
    Oct 12, 2016 at 2:44
  • Rafael's problem has nothing to do with filesystem support (see my reply), and a new macOS filesystem should have no affect on rEFInd. To the issue of EFIs and filesystems, to keep the computer bootable, Apple MUST put a boot loader on a filesystem that the EFI can read; and if the EFI can read a filesystem, rEFInd should be able to do so, too. If you're having problems with rEFInd and macOS 10.12, it's probably not the filesystem -- but feel free to contact me (I'm rEFInd's maintainer) for more advice.
    – Rod Smith
    Oct 21, 2016 at 14:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .