1

My issue is the same as in this question, but none of the answers there helped solving my problem, so I'm hoping to get alternative suggestions here.

My laptop (Acer Aspire S5-391 with Windows 10 Home 64 bit) makes an annoying beep sound whenever I plug or unplug the charger, which I'd like to disable.

The following solutions I found in the linked question and in other places did not work for me:

  • My BIOS doesn't provide a setting for power control beep.
  • My playback device settings don't show the "PC speaker" bar, so I can't mute it.
  • I don't have the Realtek audio driver, so I can't uninstall it. When I automatically search for a new audio driver via device manager, the search won't terminate. When I donwload the driver from the Acer Support site, I am only offered the Realtek driver (which seems to be a possible cause of the problem according to some sites) which anyway fails to install.
  • My device manager doesn't show Non-Plug and Play Drivers, even after enabling "Show hidden devices", and therefore I can't see and disable the "Beep" device. According to LPChip's comment on DavidPostill's answer, in Windows 10 the "Beep" entry is labelled as "System devices" > "System speakers", so see the next bullet point.
  • Edit after DavidPostill's updated answer My device manager doesn't show "system speakers" under "system devices" (which seems to be the equivalent to the above for Windows 10), so I can't disable them. Possibly my laptop doesn't have separate system speakers so the beep comes from the normal built-in speakers, in which case I probably won't be able to manipulate something in the device manager without also affecting all other sounds.
  • "Default beep" in the system sounds I already have disabled (so this apparently isn't the correct option anyway).

Gloabally disabling sounds mutes the beep, but is not a desired workaround for me - I only want to get rid of the charger beep, but still want to hear other default system sounds (or at least some, I alreay configured these in the control panel, but didn't find an option specifically for the charger beep; I think this is a matter of driver or BIOS settings rather than default Windows settings, but am not completely sure).

3

My laptop makes an annoying beep sound whenever I plug or unplug the charger.

Windows 8.1/Windows 10:

Disable the System Speaker device:

  1. Open "Device Manager".

  2. Scroll down to "System Devices".

  3. Click on "+"

  4. Right click on "System Speaker".

  5. Select "Disable"

  6. Restart your computer.

Beep should be permanently disabled.


Windows 7:

Disable the Beep device:

  1. Open "Device Manager".

  2. Go to "View" > "Show hidden devices".

  3. Scroll down to "Non-Plug and Play Drivers".

  4. Click on "+"

  5. Right click on "Beep".

  6. Select "Disable"

  7. Restart your computer.

Beep should be permanently disabled.

enter image description here

Source Disabling awful power cord beep?

  • As I already wrote in my question, this did not work for me, since I don't see "Non-Plug and Play Drivers" in my device manager, even after enabling "Show hidden devices". – lemontree Sep 23 '16 at 18:12
  • @lemontree "In Windows 10 and in Windows 8.1, the hidden devices will be listed in their usual categories of devices, but they will be grayed out. Also, you will notice that more categories of devices are displayed." – DavidPostill Sep 23 '16 at 18:18
  • I just tested this on my machine. I used this on windows 7 or earlier, but neither on 8 or 10, there's a non-plug and play drivers section. Neither is there any Beep device. – LPChip Sep 23 '16 at 18:20
  • Ah, found it. Its labelled as system devices > System Speaker – LPChip Sep 23 '16 at 18:23
  • 1
    @lemontree According to microsoft.com/Language/en-US/Search.aspx it should be "Systemlautsprecher" – DavidPostill Sep 23 '16 at 18:56
0

I'm currently using Acer Aspire 5. Everything is working fine. Audio and mic are OK. Except for the annoying beep when I plug in/unplug the charger.

So here is the fix that I found that just gets rid of the annoying beep. (The audio and mic still work.)

  1. Uninstall the Realtek Audio driver (restart required)
  2. Download the Realtek (driver only) from the Realtek official website.
  3. Install it and SHAZAM!!!! The annoying beep is gone.
  4. One last thing. You need to prevent the driver from automatically updating.(Google it.)
-1

I would suggest you to follow the steps and check if it helps.

Disable the PC Speakers and check if it helps.

  • Right click on Sound Icon in the task bar and go to Playback devices.
  • Select Speaker and click on properties.
  • Go to Levels tab, and mute (or you can reduce it) PC Speaker and check if it helps.
  • I stated in my post that simply disabling all sounds is not a proper solution for me. – lemontree Jan 30 '18 at 9:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.