3

So I automatically received the Windows 10 anniversary update this afternoon (against both my will and my explicit no-update settings) on my work computer. When I logged back in, all of my network adapters except one had disappeared (I previously had a virtual switch set up via Hyper-V to allow emulated devices to have internet access).

When I try to assign an IP address to the remaining NIC, I get this delightful message:

The IP address you have entered for this network adapter is already assigned to another adapter 'Hyper-V Virtual Ethernet Adapter' on this computer. If the same address is assigned to both adapters and the both become active, only one of them will use this address. This may result in incorrect system configuration.

It appears that the update unhelpfully uninstalled hyper-v manager, but did it in such a way that the ghosts of networks past still haunt me.

When looking in the Device Manager, the listed adapter does not appear. Having device manager 'Show hidden devices' does not make it appear either (even if I run the 'set devmgr_show_nonpresent_devices=1' command).

Ipconfig doens't list the device either.

I thought maybe if I re-installed Hyper-V I'd be able to manage it from there, but having done that and rebooted, the adapter isn't there either.

I tried removing it in Powershell via 'remove-vmswitch' but that failed saying it couldn't find such an adapter.

How can I remove all traces of this apparently invisible adapter so that my NIC starts working properly again?

2

WARNING

Insert usual registry editing warning here - in short backup your system before you mess with the registry and don't mess with it if you're not comfortable doing so.


Now that that's out of the way...

Search the following registry location for the IP address:

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces

If you find the IP address in question under a GUID key (ie {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}), then there should be a correlating key under:

HKLM\SYSTEM\CurrentControlSet\Control\Class\{4d36e972-e325-11ce-bfc1-08002be10318}\####

Which has a sub value named "NetCfgInstanceId" with the same GUID you identified in your first search.

You will also find a reference to that GUID under:

HKLM\SYSTEM\CurrentControlSet\Control\Network\{4d36e972-e325-11ce-bfc1-08002be10318}

Which has a subkey\value of Connection\Name that contains the name of the network connection as you saw it in the Network devices view from control panel (ie. "Local Area Network").

I haven't done this in Windows 10 yet, but in previous versions of Windows (7 and 2008 R2) I've deleted all three of the keys that reference the NIC/IP (do not delete the parent keys that contain ALL the NICs on the system - just the key for the specific NIC/IP you're having problems with) in order to get rid of problems like the one you're describing. At the very least you should export the keys first so that you can add them back as needed.

And, I don't remember, but I wouldn't be surprised if you have to reboot before the changes will be effective.

FYI: This same method can be used when Windows says the name you're trying to assign to your network connection/NIC is in use and you can't see it. (The name will be under HKLM\SYSTEM\CurrentControlSet\Control\Network\{4d36e972-e325-11ce-bfc1-08002be10318}\<GUID>\Connection\Name)

  • I had to find a few other instances of the GUID and remove them as well, but this did the trick, thank you! (Reboot was necessary). – hobwell Sep 26 '16 at 15:16
  • Glad to hear this helped resolve your issue. If you happen to remember what other keys you had to delete, I'll update my answer to include those for reference by other users having the issue. – David Woodward Sep 26 '16 at 17:20

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.