• After restarting computer both wireless and Ethernet adapter will not start
  • Going to device manager (devmgmt.msc) and disabling/re-enabling wireless driver allows wireless driver to work
  • Doing the same for Ethernet causes causes mmc.exe to hang and eventually fails to start driver.

Attempted fixes

In an effort to reduce generic boiler-plate answers, these are the steps I have taken to try and rule out what is causing the issue.

  • Reinstall drivers -> Failure. This yields the same result for wireless adapter as disable/re-enabling it (success). Reinstalling Ethernet adapter hangs mmc.exe, then fails with same error code (code 10).

  • Reinstall drivers using files provided by manufacturer's website (ensure using latest driver) -> Failure. Same result as reinstalling drivers from device manager.

  • Disable antivirus/Disable firewall -> Failure. Tried two different antiviruses (antiviruses integrate into firewall) Eset NOD32 and Bitdefender (Bitdefender cannot be completely "disabled").

  • Go back previous build -> Failure. No change in symptoms.

  • Reset computer (but keep personal files) -> Temporary success, restarting enough times causes symptoms to come back.

  • Clean Install -> Temporary success, restarting enough times causes symptoms to come back.


I have a strong suspicion that Windows Update may be corrupting my drivers, although at this point I would not completely rule out the possibility that an application I have installed keeps on corrupting the driver. Here is a link which encloses my installed programs.

Additional information

Events: Click here to download relevant Events (.evtx)

Ethernet Adapter Event: Device PCI\VEN_1969&DEV_E0A1&SUBSYS_11581462&REV_10\4&f8d6983&0&00E3 requires further installation.

Detailed Device Status:

This device cannot start. (Code 10)

 {Operation Failed}
 The requested operation was unsuccessful.


Troubleshooter simply says hardware or software problem. Basically the network troubleshooter says a lot about nothing.


So, resetting Windows brings "temporary success". It looks like a problem with 3rd party software (including your antivirus that cannot be disabled). Malware infection or hardware problem cannot be excluded as well.


Managed to figure out the issue by using restore points and narrowing down when the computer would exhibit symptoms.

It turns out the issue was caused by Primo Ramdisk. For some reason the software seems to cause my network adapters to not be able to start when I have a RAM disk that boots an image file on startup.

I appears this is a freak issue that is specific to the software and/or hardware because no one else has reported this issue, and I never had this issue on an older device with which I ran the software on.

Edit: (2017) Primo Ramdisk no longer causes network adapter failures.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.