1

I have two USB sticks with 32Gb each, NTFS, one is Sandisk and the other one is OCZ. Both have same bootable record inside (Grub4dos) and some ISOs.

I've tried both on different machines and while Sandisk works on all of them, the OCZ doesn't, only on some machines. On one of these machines, the BIOS labels the Sandisk as USB-FDD (if I remember correctly) and the OCZ as USB-HDD.

Today I used VirtualBox with RAW .vmdk linked to these USBs and again, the Sandisk work as expected but the OCZ worked improperly (see pictures below).

As VirtualBox has the same BIOS on both tests, I realized that there must be some differences between these two drives and I want to know what they could be.

I have checked these drives with driveman and both are labeled as fixed. I went to diskpart and the only difference I saw was that the OCZ has an active partition. I set it to inactive (so it matches with Sandisk), but the problem remains.

I still don't get why they have different behaviors, or to see the differences between both drives (what kind of tools would I need to use?).

Sandisk on Virtualbox working:

Sandisk on Virtualbox working

Sandisk on virtualbox working, commandline:

Sandisk on virtualbox working, commandline

OCZ on Virtualbox not working properly:

OCZ on Virtualbox not working properly

OCZ on Virtualbox not working properly, commanline:

OCZ on Virtualbox not working properly, commanline

  • @fixer1234 Thanks for corrections, I've learned a lot :D – Ilovelinux Sep 24 '16 at 10:28
  • Fixed this by creating a new .vmdk for the OCZ USB, previously I was using another .vmdk created for another USB (not the sandisk but a philips). Anyway I still want to know why the sandisk work and why the ocz don't with the .vmdk created for the philips. – Ilovelinux Sep 26 '16 at 10:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.