4

A strange occurrence has recently been annoying me: I usually put my computer into sleep mode rather than shutting it down, but Windows has started deciding I really want to hibernate instead. Between 1 and 10 minutes after sleeping, the computer wakes up and hibernates. It only wakes very briefly and it seems impossible to prevent it from going into hibernation, but input is nevertheless registered.

In Event Viewer the reason for the wake is the infamous "S4 Doze to Hibernate" as the Wake Reason.

By my understanding the setting governing this behaviour is the "Hibernate After" setting listed under Sleep in the settings of the current power plan. Most people seem to be able to alter this behaviour by changing this setting to a high number or to zero, disabling it. However, this setting is already zero, i.e. "Never," yet the phenomenon still occurs. I tried changing it to a very large number (999999) but the computer still wakes up. In this situation, though, it seems like the computer wakes up, attempts to hibernate and fails to do so: subsequently booting up doesn't succeed properly and the computer reboots itself.

This is pretty bizarre behaviour because it seems like it should only occur with a computer on battery power anyway. What else governs this behaviour, and how can I disable it - without also disabling some other useful feature (e.g. disabling wake timers, disabling hibernate, that kind of thing)?

  • quote: "In Event Viewer the reason for the wake is the infamous "S4 Doze to Hibernate" as the Wake Reason." Could you tell me (or provide a link that tells me) where you found this event? I've had issues with inexplicable wakes (not with Hibernation though), and I've never been able to see interesting Event Logs ... presumably I'm looking in the wrong part of Event Viewer some how? – Brondahl Nov 17 '16 at 16:53
  • They're visible in the "System" section. When it happens, note the time, then scroll down to that time and look for all the events to do with the boot - it should be one of them. I can't remember what the actual event was called, I'm afraid. – Chris Le Sueur Nov 21 '16 at 14:21
6

I believe I've found the answer to this particular problem thanks to this page.

The problem was caused by the service AdaptiveSleepServices which was included in some update to AMD drivers. I have disabled the service and switched it to not automatically start as per the page's suggestion and this seems to have fixed the problem (my computer hasn't woken up to hibernate, and it should have done by now.)

It's worth noting that, though this service is from AMD, I've switched my graphics card to an nVidia one so have no AMD hardware running any more and have completely deleted AMD drivers using Driver Sweeper. This did not get rid of the service.

Why on earth AMD includes this trash in its drivers when there is a perfectly serviceable API for performing the same function is, unfortunately, plainly obvious: incompetence.

5

I have been seeing the same thing happen in the middle of the night. I'm asleep and all of a sudden the room is lit and my laptop is awake. I got to this page because of the same message in the Event Viewer: "S4 Doze to Hibernate".

The answer provided here, suggesting to take a look at AMD drivers, didn't help me since I'm not running any AMD hardware. Another website provided me with the answer and I thought it might be useful to share the solution here as well.

Source: http://mikeberggren.com/post/113733489241/wake-up

Follow these steps and change the values for both 'Battery' and 'Plugged in' to never (0). Don't forget to apply the same changes to the power plans that are not active.

Control Panel -> System and Security -> Power Options -> Change plan settings -> Change advanced power settings -> Sleep -> Hibernate after -> Setting:Never

This solved the problem for me.

  • 4
    This question was explicitly about the situation where the "Hibernate after" setting does not work, and I already detailed that in the text of the question. Note also that in my answer I point out that I don't have any AMD hardware any more, and your answer incorrectly implies that if you don't have AMD hardware this cannot be the cause. – Chris Le Sueur Feb 23 '17 at 16:17
  • The solution posted by Gijzz is valid and will be helpful to many. It addresses the problem posted in the title. I would not have thought to check power plans that were not currently active. For example, every time I use "Airplane Mode" from the notification area, something (Windows 10? Lenovo Vantage?) changed the power plan to "Airplane", which I didn't realize was happening. The primary power plan I set up wasn't being used and my laptop would wake up inside my bag just to hibernate (real safe, great default, NOT). Not knowing airplane mode changed power plans made it harder solve. – Ryan C. 2 days ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.