"New Folder" command (from windows explorer) creates 4 folders on Windows 10 Pro - July 2016 release. This issue however doesn't occur on Windows 10 Enterprise or on Windows 10 Pro - July 2015 release. Steps to reproduce:

  1. Right click on C drive->Properties->Security->Advanced
  2. Select "Authenticated Users" Principal and "Modify" access entry
  3. Click on "Change permissions"
  4. Select "Authenticated Users" Principal and "Modify" access entry
  5. Click on "Remove"
  6. Click on "Apply" or on "OK", it will pop up few security warnings, click "Yes" on all those warning messages.

Now create a folder on C drive root, it will create 4 "New folder" entries. Ctrl+Shift+N behaves same, however from a command prompt it works fine.

Win 10 enterprise and earlier release (July 2015) of Win 10 Pro seems to be working okay.

  • 2
    I was unable to reproduce this error on my machien running Version 1607
    – Ramhound
    Commented Sep 26, 2016 at 16:15
  • 2
    I can reproduce this on a 14939.51, but what is your question? It is a bug in Explorer. After creating a folder, Explorer seems to want to perform another CreateFile operation on it which fails with an Access Denied, it tries again three times and then gives up. Commented Sep 26, 2016 at 16:29
  • Thx Peter, I just wanted to confirm if anyone else has seen this behavior or I was doing something plain wrong. I will create incident with Microsoft. Commented Sep 26, 2016 at 16:47

6 Answers 6


If anyone searches and finds this as part of a Linux/Samba/Share, here is the issue (which was self induced).

I had this problem, and discovered it was because I was fiddling with the creation rights in the /etc/samba/smb.conf file. I was trying to stop it from setting the eXecute bit on new files.

By setting the rights on directories, removing the 'x', the Windows Explorer appears to be creating the folder then trying to access it. As Peter points out, it tried a total of 4 times.

By setting the /etc/samba/smb.conf file back to

directory mask = 0775

It eliminated the problem.

Hope this helps someone.


This happened on my machine due to me fiddling with some permissions with Cygwin and on my dual boot system that could access the same files on both OS's. It is possible to get the permissions back to the way it was via Cygwin or Bash for Windows (or something similar). I had write something like below for whatever folders that had this issue. Not sure which folders exactly you are having problems with, but it would be good to mimic what was there before (unless you have an idea what you need to change the owning user to)

chown -R <user>:Administrator <folder>

You may need to do some chmod if the permissions themselves are borked. In which case, you'd have to write:

chmod xxx <file>

Where xxx is whatever permissions value you want. Again, mimic what was there before unless you know what it is supposed to be.

  • There is no mention of Cywin or Bash for windows in the question. It is a bug in explorer.
    – DavidPostill
    Commented Dec 9, 2016 at 13:26
  • Yeah. I suppose my answer is a workaround then.
    – henry
    Commented Dec 10, 2016 at 21:42
  • Not really. The OP isn't using Cygwin. It's nothing to do with folder permissions.
    – DavidPostill
    Commented Dec 10, 2016 at 21:45

I faced the same problem and this is how I solved it:

  1. Open your Task Manager
  2. Find Windows Explorer and right click on it.
  3. Select End Task (you may select Restart, but it didn't worked in my case)
  4. After this all running Windows Explorer instances will be closed. Start menu, Taskbar or Run command wont work.
  5. Alt+Tab navigate to Task Manager
  6. Click on File > Run New Task, the Run window will appear
  7. Type explorer.exe in the text box and press enter

After new Windows Explorer instance will start. Now (hopefully) the problem wont persist.


I have tried just now changing the permission in the Security of that particular folder and it worked for me.

  1. Right click > Properties > Security > Select an user name for which the permission is needed.

  2. Click on Edit button > Select Full Control > Apply > OK

Now try creating a folder and the issue doesn't exists. Hope this helps !!


The issue occurs when the top directory has deny permission for Delete and Delete folders and files.

Right click on the top folder > Go to Security settings > Advance > select the user/ group and check the permission. tick the box for Delete. Apply and OK.


On Server 2016 I have found that removing user 'CREATOR OWNER' from a drive (that had 'special' permissions) seemed to cause this to happen. But strangely this doesn't seem repeatable. https://answers.microsoft.com/en-us/windows/forum/windows_10-files/new-folder-command-creates-4-folders-on-windows-10/9233ca20-8d16-44f2-b7b4-abe7b66a752c 'Bitdefender' may be a factor

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .