0

I want to dual boot kali linux. I'm mounting kali linux.iso to create a bootable USB with the help of Rufus. Rufus shows the following errors when i start the process.

Rufus bootable error

It asks for download some file which I've no idea what they are and why Rufus seems so interested in downloading them before creating bootable USB. Is there any way to get around this error?

Edit: Issue resolved

2

ldlinux.sys is the name of the bootloader file used in SYSLINUX and ISOLINUX (used for booting Linux off of FAT32 and ISO9660 filesystems, respectively). It is loaded into memory by the BIOS on bootup. The loader then parses the configuration file (syslinux.cfg or isolinux.cfg) to know which kernel to launch, along with parameters to be passed to it.

Essentialy you need these files or else linux will not run.

  • I've downloaded kali linux from their official site kali.org. Aren't they responsible to include these 2 files in the disk image? I think I've to download these 2 files manually but in which directory I will need to copy them? – defalt Sep 27 '16 at 11:00
  • Any reason why you dont just use Rufus? – Dylan Rz Sep 27 '16 at 14:01
  • I often use it. I've downloaded the files but I don't know where to copy them. It's surprising, I also used rufus for creating bootable USB of windows 10 and it did work fine but I don't know what's wrong with it this time. – defalt Sep 27 '16 at 15:22
  • I solved my problem by copying the files into rufus download directory. Rufus is fast. I prefer rufus over other boot creating utilities. – defalt Sep 27 '16 at 15:45
  • ye I use rufus aswell, But when I use it it copies the files directly into the directory so thats weird. But I am glad you solved it. – Dylan Rz Sep 28 '16 at 6:08
2

You do realise that this is NOT an error message, but just a prompt asking for your permission before downloading a file off the internet (which is more polite than an application that connects to the internet, without asking permission first).

As the prompt indicates you just had to "Select 'Yes' to connect to the internet and download the files". That's all.

  • I understand that but I've also got an opportunity to learn what these files do. Earlier, I didn't know what they were. – defalt Sep 28 '16 at 14:04
  • My problem didn't end up here. Bootable USB is not booting. You can help me here: unix.stackexchange.com/q/312965/192349 – defalt Sep 29 '16 at 2:40
  • 1
    The problem described in this issue (unable to create bootable USB) does actually end here. You were able to create your bootable USB, boot from it, and subsequently got an error, that is unrelated to the bootable USB creation. I hope you will get help on the other thread, but as far as this one is concerned, it was successfully resolved. – Akeo Sep 29 '16 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.