0

I noticed a weird problem today on my laptop. Apparently, it only connects on the Ethernet cable located on to my desk but not in any other port in my office. When I tried to get connected using a land cable of a different desk, the networking icon on the status bar showed an exclamation mark and refused to connect. Though this is a large company I am working at, they have not applied any restriction policy "laptop per Ethernet plug", so it must be something software or hardware specific. I have tried to release and renew my IP address, reinstalled from scratch the network drivers and contacted the IT help desk; no fix so far.

Is there any possibility that my network card starts degrading or is in a bad state? The laptop is only 6 months old. I have tried with multiple land cables and different plugs, it connects to my desk only.

PS: Laptop successfully connects to the open WiFi of my company and to networks outside the intranet.

3
  • 4
    The fact that your laptop connects fine to networks outside of the company makes me think that this is a network issue within the company network. I don't know about your company, but IT help desk people are usually not the network administrators or technicians. Try to talk to one of those instead, if you can, or try to get the help desk to talk to them for you. – Chris Oct 6 '16 at 13:51
  • Try to disable IPv6 on the network card. Look for interesting errors in the Event Viewer. – harrymc Oct 8 '16 at 15:38
  • Is there a way you can change your MAC address so the network gives you a new IP address? – Nathaniel M. Beaver Oct 12 '16 at 23:17
2
+25

That exclamation mark means there is a problem with DNS. Windows tries to resolve some known DNS names and then if it fails tells you that there is no Internet access.

More than likely, there is some config or setting applied to the network and the people you've talked to just don't know about it. You will need to do a lot of things to troubleshoot this:

  1. See if the LEDs on your NIC light up. if they don't, there is nothing on the other side of the cable.
  2. Make sure the adapter is enabled in the Network and Sharing center
  3. Try a different cable.
  4. Test the cable to make sure it's TIA-568B.
  5. Try a different switch port.
  6. Try a different switch in the rack.
  7. Try a different PC/device on that port in the wall.
  8. Tell us what the IP settings for that NIC are (static, DHCP, IP address, etc).
  9. If you have a 169.254.x.x address, then that means DHCP is failing.
  10. If DHCP is working, find out if the DNS servers being handed out on the problematic port are the ones you are supposed to get.
  11. Ping the gateway and DNS servers. They should respond.
  12. Change your DNS servers on your NIC to something public with a high uptime like Google, OpenDNS, or whatever you prefer.
  13. As a last resort, you could get your IT people to come to your office/site to fix it.
4
  • Answering the bullets. Keep in mind that the final bullets do not apply, as the cables are not recognized by my laptop. It's like it is not connected to anywhere. * They don't light up * I tried. Not working. * It is. * I tried. Not working. * I can't. This is a corporate network, I can't walk into the computer room and change the switch. * I tried. Not working. * Static. * No, I have my company's IP. – Lefteris008 Oct 6 '16 at 13:56
  • 1
    You asked the question, I answered it. If you don't have the technical abilities, that's fine, but you need to find the people who do and start on these tasks. That may sound harsh, but this stuff is not magic, and these are the steps that need to be done to troubleshoot this. it is too easy to ask a question and not be able to understand the response; especially with technology. – YetAnotherRandomUser Oct 6 '16 at 14:03
  • I can't figure out what's your problem, you asked some questions in bullets and I answered them. Obviously, for some technical ones, I am not privileged to test them (like changing the switch etc). As for the final ones, the cables I connect are not recognized by the laptop so I can't ping the DNS servers or change them; there is no connection. Is there a reasonable explanation besides that the network card starts degrading? – Lefteris008 Oct 6 '16 at 14:08
  • "Network card degrading" is not even in the same realm as reasonable. Solid state stuff either works or doesn't. It's possible that your NIC is dead, but that's no likely given the circumstances that you've described. It's fine if you're a nontechnical user, but you have asked a question that you can't parse/handle the answer to. Don't get upset at someone trying to help you because you don't understand what needs to be done. This may be pedantic, but I did not ask you a single question. I gave you instructions to carry out. – YetAnotherRandomUser Oct 6 '16 at 14:15
0

Here is my answer and a comment to Dan Whaley, because I can't comment directly.

@Lefteris008, indeed what Dan says is true. It will be difficult to answer your question with 100% certainty without having access to the equipment.

But I think I can provide a good approach nevertheless. There are 3 possibilities, 2 more probable and a 3rd way less likely.

1) Most probable:

The other unused ports are not connected in the switch. This is quite common to save on switch ports and cabling. You may test if this is the case by unplugging another guy's computer and pluggin yours.

2) Second most probable, possible the answer if the previous experiment failed:

I wouldn't discard the fact that your MAC address has been restricted to connect to only one port in the switch. This is done in the switch configuration and is quite common in big corporations. Reasons to suspect this:

  • You get a connection in your seat, this means that everything works properly when you're in your seat.
  • You don't even get the most basic network connectivity when you try the other connectors, as no leds light up (Behavior that you get if there is no cable or the switch port is blocked).

3) The third possibility: Your card degraded as you say and you're in a port that has a better SNR than the others, but this seems a very very big coincidence and although possible, it is unlikely.

@Dan Whaley: Network cards DO degrade as all electronics do. At the lower level, you always work with an analogic Signal-to-Noise ratio(SNR), as the real world is not digital.

I've seen computers failing to connect to a certain network due to the use of a longer cable (which would cause a lower SNR). That same cable would be good for a different card.

4
  • My guess is #2. We do this at my government agency to prevent someone from flooding the CAM table in the switch, or doing MAC spoofing. It's often referred to as Sticky MAC or Port Security (Cisco). Your MAC is tied to a specific port and won't release until you reach a certain interval or the CAM table is flushed. Check with your IT help desk or network team to see if they have this enabled. – PTW-105 Oct 10 '16 at 23:43
  • It's possible that they degrade-but-not-fail, but not very likely (especially with consumer hardware), and on top of that, this discussion is way out of the technical capabilities of the OP. I find that nontechnical people focus too much on "the why" and get lost in the weeds and falling down all the rabbit holes and none of that effort is put to doing what should be done. #squirrel – YetAnotherRandomUser Oct 11 '16 at 19:11
  • While the problem does sound like Sticky MAC / Port Security, the OP says she talked to the resident experts "Though this is a large company I am working at, they have not applied any restriction policy "laptop per Ethernet plug", ..." – YetAnotherRandomUser Oct 11 '16 at 19:13
  • Yes, that's why unplugging another computer and plugging the laptop instead would clarify the situation. We would be sure that the port has been wired and we'll know if it allows any mac or not. – Telegrapher Oct 13 '16 at 2:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.