0

Windows 10 recently updated to the anniversary edition (10.0.14393 Build 14393.187). Since then, when I click button 5 (near my right thumb), the current app maximizes to the left half of the screen and other open windows shrink and tile on the right half of the screen. The opposite happens when I click button 4.

The mouse is a Logitech G700s. I haven't installed any Logitech drivers or software. I just relied on the default Windows HID support.

The mouse works for all of my apps without issue except this new behavior is annoying when using the browser. I would like for buttons 4 and 5 to for forward/back in the browser.

It used to work like this until the Windows update.

Does anyone know how to restore the original mouse functionality when in the browser?

2

This issue has nothing to do with drivers and the other answers are all wrong.

This has to do with the built in profiles of the mouse since it has on board memory. There are 5 profiles and you change these (default button) is the g11 button which is under the mouse scroll switch button. Its why it works correctly when LGS is on and you have the mouse switched to auto game detect mode. If LGS is not on or has crashed which is frequent with anniversary update, the mouse auto switches to on board memory mode.

To fix - simply click the g11 button again.

To fix permanently

  1. Open LGS
  2. Switch mouse to On-Board Memory
  3. Select profile button and take a look at your profiles.
  4. Most likely this is set on profile 5 which has a multikey macro on both buttons.
  5. You can either disable all but 1 profile and customize it as you like or just disable 6 as the rest seem similar. Personally I would just disable all but 1 and set it up how you like your mouse.

This will also fix if your g700 mouse suddenly slows down and it feels like input lag. Its more likely LGS crashed and your mouse switched to on board memory.

This fix is only for LGS mice with on board memory, but it would most likely only happen with those mice also.

LGS On Board Profiles

  • Exactly the problem I had. I didn't recall any of the default profiles having the buttons swapped, but I confirmed that profile 1 somehow had this setting. This was on a g502 mouse. – djs Jun 7 '17 at 4:00
1

Visit the Logitech website and download the Logitech Gaming Software here select your windows version as 10 and your architecture. If you don't know select 32bits. This should solve your issue, if not try the following:

Once installed open it and click on the "mouse" image. Here you can create a new profile or edit the current one. Just select the buttons you want to edit (right click edit) and add the keystroke you want to add. If you use Firefox visit the Page Navigation Shortcuts here and use the key combination you prefer. For other web browsers type in google the name your preference + Page Navigation Shortcuts. I recommend you the use of Firefox as your primary browser.

  • Installing the driver is the right way to go. – robx Sep 28 '16 at 5:21
  • While I'm guessing that this will work, I never had this problem until after Windows 10 updated. Why did the default button mapping change? Is there a place in Windows where these button defaults are set? – Chris Dunaway Sep 28 '16 at 18:34
  • Drivers are little programs that understand your hardware language. Windows try to have those drivers naively for default so you don't have to mess around installing anything, just plug and play. Hardware manufactures write their drivers using specific rules every OS sets. When you change versions of OS drivers can misbehaver or simply not work ar all. That's why you (or your OS) must update your drivers every major versions. Don't forget to mark this as the answer if I am helpful. – Joe Sep 29 '16 at 5:08
0

Like Stah said, "To fix - simply click the g11 button again," however... it's slightly more complicated than that:

Go to google, search something, click a result. (This sets you up to verify "back" button actually brings you back a page.)

Then:

  1. Hit G11
  2. Hit Back button on mouse
  3. Repeat until it works.

I have a G700s and I was playing with the G11 key (center-top of the mouse, under the scroll wheel) the other night, and that's about when the issue started for me. So I wanted to play with it a bit and it would seem that the G11 key does have some effect on the thumb-button mappings. Maybe a Logitech manual talks about it somewhere - I'm not going to take the time to look it up, though. Thanks for the lead in the right direction Stah!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.