4

I have a mini PC connected to my TV with Windows 10. I "control" it with VNC. TightVNC is installed as a service on the PC. My client is Hippo LITE on iOS. This works fine when there is a mouse plugged into the PC (even though I don't use the mouse, but my VNC client). When there is no mouse device plugged in the pc, I cannot see a cursor. The cursor disappears as soon as the mouse is unplugged.

How can I keep the cursor when there is no mouse plugged in?

6

You can try turn on mouse keys feature (when it enabled mouse cursor always is always displayed):

  1. Open Control Panel
  2. Open Ease of Access Center
  3. Click Make the mouse easier to use
  4. Click on the Turn on Mouse Keys box
  • This doesn't work. Even when this is turned on, the cursor disappears as soon as the physical mouse is unplugged... – user1073075 Oct 3 '16 at 17:37
  • This worked well for me using a Windows 10 host PC, TightVNC server and RealVNC viewer. – leinad13 Jul 20 '17 at 13:52
  • @leinad13 do you have a keyboard connected to your host PC? – user1073075 Aug 3 '17 at 17:18
  • I didn't have a physical mouse or keyboard connected when I tried the mouse key's feature. Enabling Mouse Keys displayed the cursor. – leinad13 Aug 14 '17 at 15:23
  • That just doesn't work for me when there is not physical mouse or keyboard connected... – user1073075 Nov 14 '17 at 12:05
2

So I did some testing, people have posted the correct solutions here but the order of operations makes a huge difference.

Firstly some points to get right:

There's kind of two ways to enable/disable Mouse Keys:

  1. In the Settings panel ui: enter image description here

  2. Once Mouse Keys is enabled as shown above, you can enable/disable it with different key strokes depending on how Mouse Keys is setup: enter image description here

To make things even more confusing the old-style Control Panel ui has some slightly different options. I accessed this panel by double-clicking on the Mouse Keys tray icon: enter image description here

When enabling/disabling Mouse Keys use the newer Settings window, not the older Control Panel window. Checking the disable/enable checkbox in the old ui does not seem to work.

So in the following steps when I'm talking about disabling Mouse Keys, I mean method #1 in the Settings ui, not #2. You can tell if Mouse Keys is properly disabled when there's no tray icon for it anymore.

The next main thing to get is that the act of physically removing a mouse is what causes windows to hide the cursor. Even if you get the Mouse Keys config right, as soon as you physically unplug the mouse the cursor will probably disappear.

The only way to make it re-appear using Mouse Keys is to Disable -> Re-Enable the entire Mouse Keys system, ie method #1 above. Just toggling it with Num-Lock won't work.

The trick is this has to be done after you've unplugged your mouse.

So:

  1. Completely Disable Mouse Keys in Settings.
  2. Unplug any pointing devices
  3. Enable Mouse Keys in Settings.

You can use tab and arrow keys to navigate to the correct ui without a mouse. Once you've highlighted the Mouse Keys On/Off toggle use spacebar to toggle on/off.

  • Completely Disable Mouse Keys in Settings -> Unplug any pointing devices -> Enable Mouse Keys in Settings = nice solution dude – Yohanes AI Aug 8 at 5:46
1

I've tested all given answers, however, the real solution (tested on a clean setup) is:

  1. WIN + R -> ms-settings:tabletmode -> Select "Take me to the desktop/desktop mode" & "Don't ask me and don't switch"
  2. WIN + R -> control access.cpl -> "Make the mouse easier to use" -> Turn on "Mouse Keys box"
  3. Press "LEFT SHIFT + LEFT ALT + BLOQ NUM" a couple of times until an ugly popup appears asking you to (again) Enable "Mouse Keys", click Yes.

Try disconnecting your mouse, it should now keep visible :)

  • Didn't work for me... – user1073075 Nov 14 '17 at 12:06
  • Did you restart after following the steps with the mouse disconnected? If not, try it. Once you replug the mouse, disconnecting it will again hide the cursor until you restart. Its windows, don't expect good software. – FrakyDale Nov 15 '17 at 12:20
  • What does BLOQ NUM mean? – Steve May 1 at 20:44
  • NUM LOCK in your country – FrakyDale May 9 at 7:40
0

How to Fix Mouse Disappearing Issue?

To fix mouse pointer disappearing issue, step-by-step instructions given below should be followed:

1.Log with the administrator account.

2.Click Desktop tile from the Start screen to go the desktop window.

3.Once on the desktop screen, hover mouse to the bottom right corner.

4.From the displayed options, click Settings.

5.From the Settings pane, click Control Panel.

6.On Control Panel window, click Hardware and Sound category.

7.On Hardware and Sound window, click Mouse under Devices and Printers category form the right pane.

8.On the displayed Mouse Properties box, go to Pointer Options tab.

9.On the selected tab, uncheck Hide pointer while typing checkbox under Visibility section.

10.Once done, click OK to save the modified changes.

11.Close Hardware and Sound window when done.

Taken From: http://www.tomshardware.com/faq/id-1656322/windows-mouse-cursor-disappearing.html

0

I ran into the same problem, and found an easy solution on another forum:

Quote : "I know its old, but it is still coming up in google searches.. Enabling Mouse Keys worked for me. I am on win 8.1 Just went to the start menu, typed in mouse > down aarowed to the Ease of Access mouse> tabbed twice to the settings and flipped the switch for "Use numeric keypad to move mouse around screen" and voila, it worked."

Origin forum : https://groups.google.com/forum/?fromgroups=#!topic/input-director/cO4LH8UjxFc

Screenshot windows 10 : Mouse accessibility options

Work quick and easy for me =)

Cheers !

-1

If it's a PS/2 mouse, you MUST power off the computer completely to get the mouse back. (Make sure it's plugged in, of course). If it's USB, then unplugging it and plugging it back in may work... or you can try a different USB port if it doesn't. (Plugging into a new port usually forces Windows to reinstall the driver).

  • This isn't relevant to the question... – leinad13 Jul 20 '17 at 13:53
  • PS2 became plug and play via reporting 'permanently connected' a long time ago. MS takes care of whether it's actually there or not in software, as do Linux and others. – user1901982 Dec 12 '17 at 22:28
-1

If you already enabled Mouse Keys, try to disable and re-enable it after unplugging the mouse. Works for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.