0

I'm new to the world of linux andI have mounted a hard drive on my linux system as such:

mount /dev/sdb1 /opt/backup

I have my samba share pointing to the folder /opt/backup. When /dev/sdb1 is not mounted I can access the folder called backup but when I try accessing the same folder when the drive (sdb1) is mounted I get an error that I don't have permissions to use this network resources.

I'm using MS Windows 7 to access the Samba share.

  • The drive that you are able to access is just the symbolic link path created in the linux machine. Please check the permission provided for the share in source – vembutech Sep 29 '16 at 13:43
0

I resolve the issue by adding the mount to fstab and setting the permissions of the folder as followed:

chmod -R 777 /opt/backup
chown nobody:nobody /opt/backup

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.