1

I have a Windows 10 1607(anniversary update) system Acer R5-471T. And my wifi card is Qualcomm Atheros QCA61x4A Wireless Network Adapter. And I have the problem as stated. I am unable to connect to a network which is broadcasting on channel 13. And on Kali Live. I am able to connect that channel 13 networks. So my card does support it. And I tried

  1. updating the driver from official acer sites.

  2. Nor does I have ad hoc settings on the device manager setting.

  3. Nor does enabling and disabling wlan card works.

  4. Changing country and region also didn't work.

And i am trying to fix the problem for a long time now. And I can't change the channel of Router to a range of 1-11.

Edit: I tried to configure it for another country with full restart. for fastboot restart. It didn't work.

  • Where did you try changing the "Country and region"? – Ƭᴇcʜιᴇ007 Sep 29 '16 at 15:35
  • in windows region settings – Kishan Kumar Sep 29 '16 at 15:36
  • in the new settings menu of windows 10 – Kishan Kumar Sep 29 '16 at 15:36
  • Check under the WiFi adapter's Properties > Advanced for a "'Country Region (2.4GHz)" option (or similar). – Ƭᴇcʜιᴇ007 Sep 29 '16 at 15:38
  • 3
    Channel 13 is not legal in North America. Check that you did not configure your windows OS for that region. After that reboot (full reboot please, not a windows 10 fastboot which keeps kernel and drivers loaded) and try again. If that did not work then please mention that in the post. Also see this list for legal channels: en.wikipedia.org/wiki/List_of_WLAN_channels – Hennes Sep 29 '16 at 15:54
1

I had this same problem with another card (BCM), somebody in the forums suggested that and it is a matter of the driver itself. Initially I didn't want to believe this, but finally I have also reached the same conclusion.

For your reference, I had examined all your steps in the past, because I read some people's problem were solved by reviewing these settings:

  • Driver updated to the latest from the manufacturer web site OK: I guess this is the source of the restriction.
  • The card does not have an specific setting for the country or channel restrictions OK: device manager > select wireless card > properties > advanced tab > nothing.
  • My laptop is originally installed in Spanish (allowed ch 12/13), and all language settings are OK, including the special one: control panel > region > administrative tab > copy config.

The fact is that the primary card does scan those channels 12/13 (intel 7260), while the USB dongle won't (BCM43526), at the same time on the same PC, with verified configuration. Thus it can only be a driver issue, such as being hard-coded by code or being just an US-only driver.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.