1

I have recently set up a new install of Windows 7 and I have just noticed that when alt-tabbing I am not getting Aero-Peek previews as I am accustomed.

I have checked to make sure that aero-peek is enabled in both the taskbar properties (and taskbar icons do show previews!) as well as in system performance settings. Both are enabled.

I even looked at a couple of registry edit solutions, but the key I am supposed to edit is not present (adding it did nothing). Even Alt-Tab Tuner hasn't solved the problem.

Any other ideas?

  • Have you installed the latest graphics drivers? – Mr. Hargrove Sep 29 '16 at 17:46
  • @Mr.Hargrove Yes. The driver was issued two weeks ago. – Draco18s Sep 29 '16 at 17:51
  • 1
    and you've tried looking in the registry for: HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM See the right side, you'll find a DWORD value called EnableAeroPeek and set it to 1? – Mr. Hargrove Sep 29 '16 at 17:55
  • @Mr.Hargrove It is already set to 1. – Draco18s Sep 29 '16 at 18:09
  • one more troubleshooting step: support.microsoft.com/en-us/kb/976170 – Mr. Hargrove Sep 29 '16 at 18:16
0

You may try to perform a clean boot on the computer and check if any of the 3 party programs are causing the problems. Make sure that you put the computer back in normal startup after clean boot troubleshooting.

To perform a clean boot on a computer that is running Windows 7:

kb929135

  • Sadly...that didn't help. Even under a clean boot I didn't have aero preview during alt-tab. – Draco18s Sep 29 '16 at 18:36
  • @Draco18s What version of Windows 7 are you using? – Mr. Hargrove Sep 29 '16 at 18:47
  • Windows 7 Pro. And yes, it was legally purchased. – Draco18s Sep 29 '16 at 19:40
  • 1
    Thanks. And yeah, when I noticed it I was like, "that's odd" and everything I knew about it and everything I could find didn't work. I am not even positive that it was ever working correctly. – Draco18s Sep 29 '16 at 20:25
  • 1
    I go gaming for an evening and I come home to find that it works now. WTH. Only thing I can think of that I did after getting home that would have even come close to affecting this was rebuilding the icon cache (because a program in my start menu had a generic icon, rather than it's program icon). – Draco18s Sep 30 '16 at 4:50
0

I have both discovered the cause and the solution to my issue. I had wondered about the cause earlier, but it was such tenuous speculation I didn't even mention it.

Installing Dropbox broke Aero Peek.

Fixing it requires doing the following:

Does not appear that the order matters, as the first time I fixed it I'd previously restarted the computer to no effect and as soon as I rebuilt the icon cache, it worked. After reinstalling Dropbox (in an attempt to get it to locate its executable anywhere but the C drive), rebuilding the icon cache was insufficient and as soon as I restarted the computer, it worked.

Computers run on black magic. That's the only explanation as this entire series of events makes no sense.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.