0

I'm installing Ubuntu 16.04 on a Dell XPS 13 with Windows 10 already installed on the SSD.

In Windows I've:

  • Ran disk management to create 90 Gb of unallocated space
  • Ran error checking and optimization on the resulting shrinked c:\ drive
  • Turned off fast startup under Power Options.
  • Verified with System Information that my BIOS mode is UEFI
  • Verified that my machine is 64bit

My Ubuntu USB was created with Rufus

  • Is was created with a 64bit ISO
  • I've tried all the available partition/firmware combinations

I've also

  • Turned off Secure Boot in my BIOS
  • Ran the USB "Check disk for defects" options successfully

When booting into Ubuntu from my USB, I pick the option in my boot menu labelled: UEFI Boot

During the install, I get no options on the installation type, clicking any button other than Quit causes the install to crash. I get the same behavior whether I boot directly to the install from Grub, or click the Install icon from the Try Ubuntu desktop.

Under the dropdown for "Device for boot loader installation:" the only option is "/dev/sda".

When running Gparted under the Try Ubuntu desktop, the only device I see is the flash drive under "/dev/sda" with one partition "/dev/sda1" with the Ubuntu installation.

What step am I missing, or what problem do I probably have?

4
  • I've always run Ubuntu Live and installed from the desktop. This allows me to run a number of pre-checks first, including running gparted to check the partitions from an Ubuntu perspective. I can't say I've never had problems, but I've never had this problem. I found the automatic partition selection didn't always work, but I've always been able to use manual configuration. I haven't disabled secure boot, though this has caused a few issues where I've needed to sign drivers and kernel modules manually. – AFH Sep 29 '16 at 21:23
  • Updated question with my gparted results. How could I proceed when gparted only sees the flash drive? Or what other tests could I run? – Thomas Langston Sep 30 '16 at 12:10
  • I have no idea why Ubuntu is not seeing the hard disc, but it explains what is causing the installation to fail. Have you tried setting Secure Boot / UEFI? Otherwise, lshw may give a clue: either scan the output using lshw|less, or install the GUI interface lshw-gtk. My hard disk appears under scsi:0 (slightly confusingly, because it's SATA). But it is unusual for Ubuntu not to find a hard disc: the hardware support is often better than Windows. – AFH Sep 30 '16 at 13:07
  • (For the record, I installed from the Ubuntu 16.04.1 Mate installation disc.) – AFH Sep 30 '16 at 13:09
0

The answer was that I hadn't set my BIOS Intel Rapid Storage Technology aka BIOS Raid to AHCI, even though my SSD was not set up in RAID configuration. Doing so makes Windows unable to boot, but does let me install and use Ubuntu.

I'm still trying to figure out how to get Windows 10 to work with AHCI, but am finding multiple conflicting answers as to which registry keys to change. Or I would like to get Ubuntu to work with Intel Rapid Storage Technology, but the instructions I've found for that are complicated and not well documented.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.