32

I work for a growing online company that recently re-branded itself as "mycompany" (not its real name but the real name has all lower case, no space between words). I am trying to find a way to force Microsoft Word to never auto-capitalize the name "mycompany", whether it is at the beginning of a document, paragraph, or sentence. I am having no luck so far.

I reviewed the documentation related to AutoCorrect and I know that there appears to be a way to prevent Microsoft Word from auto-capitalizing "mycompany" at the beginning of a sentence by going to Options → Proofing → Autocorrect → Exceptions....

However, when I add "mycompany" into the "Other Corrections" tab and say "Don't Correct", Microsoft Word continues to do so by capitalizing the "M". It's extremely frustrating.

I invite you to try it. Go to Options → Proofing → AutoCorrect → Other Corrections → Don't Correct, enter "mycompany", and then test it out in a document. Microsoft Word continues to automatically capitalize "mycompany" at the beginning of documents, paragraphs, and sentences, although I've specifically told it to NOT auto-correct!

Is this a bug in Microsoft Word or am I configuring something wrong?

5
  • I get the same results. Report it to Microsoft.
    – Jeter-work
    Sep 30, 2016 at 12:09
  • 19
    For what it's worth, the Wikipedia Style Guide has this to say about trademarks that begin with a lowercase: 1) They should be capitalized anyway since they are a proper name; except 2) if it begins with an initial lower followed by an uppercase; and 3) Rephrase so that the word does not begin your sentence or paragraph. Sep 30, 2016 at 15:24
  • 28
    As a side-note: Lack of capitalization where capitalization is due leads to slower and awkward reading (not to mention inconsistencies between your own and other third party texts). In my opinion, weird spelling rules for trademarks deliberately worsen the communication Sep 30, 2016 at 20:17
  • After some testing, this appears to be a bug in Microsoft Word. I am using the latest version of Office and the most current available build of Windows 10 (Anniversary Update), and when I choose 'Stop Auto-Capitalizing first Letter of Sentences', it does just that.
    – delete me
    Oct 1, 2016 at 11:35
  • Having a lower-cased word begin a sentence simply looks wrong. It looks like a grade school kid wrote it. I don't know what advantage you gain by associating your company name with an internationally recognized mistake. I mean, foreign people who read it will immediately point to it as a mistake.
    – Nelson
    Oct 3, 2016 at 6:48

6 Answers 6

40
  • Under Word Options, select Proofing.
  • Select Autocorrect options.
  • Enable "Replace text as you type."
  • Enter your company name to be replaced with the lower case variant (e.g. Mycompany to mycompany).

Word will now automatically replace the word with the intended phrase. But you will have to type it in caps to start off with for the correction to occur.

Essentially, this swaps the functionality of the Caps key for the first letter of the particular phrase.

7
  • Would that only work if the user types it with the initial capital? It looks like what is happening is that he types it with a lower, then Word makes it upper. Or, does this happen AFTER Word capitalizes it?
    – krillgar
    Sep 30, 2016 at 17:44
  • Yes, this only works if the user type it with the Initial capital. Typing with a lower will revert it back to a capital. Essentially this reverses the caps lock functionality for the word.
    – Carrein
    Sep 30, 2016 at 17:47
  • 9
    You could take this a step further by putting something \mc into the autocorrect to replace with mycompany. The autocorrect isn't capitalizing the first word of a sentence with the backslash autocorrection.
    – OpiesDad
    Sep 30, 2016 at 18:07
  • 6
    I wonder, if you add two aliases (Mycompany -> mycompany, but also mycompany -> mycompany) if that would be enough to subvert auto-capitalize?
    – jpaugh
    Sep 30, 2016 at 21:00
  • 6
    @jpaugh that may just cause an infinite loop as Word tries to correct itself, then applies the alias, then corrects that, then... Either that, or it will just tear open the space-time continuum and we'll all end up dead. If that happens, we'll know who to blame. ;)
    – FreeMan
    Sep 30, 2016 at 21:03
18

Unfortunately, Auto-correct is for correcting spelling, etc, not to ignore basic English syntax.

To get Word to not capitalize your company name at the beginning of sentences, etc., you need to disable that feature for all words.

You can do this in Word's options...

In 2013, its under File :: Options :: Proofing :: Autocorrect Options... and it's an option called "Capitalize first letter of sentences":

enter image description here

Alternatively (perhaps once you're done writing the Word document) you can replace all occurrences, forcing the all-lower case version, by using Word's Search and Replace. This works because when you use replacement text from the clipboard, it doesn't auto-correct it...

  • Type "mycompany" someplace in all lowercase.
  • Select it and copy it to the clipboard, and then deselect it by clicking elsewhere in the document.
  • Hit Ctrl+H to open the Replace dialog.
  • In "Find what:", enter Mycompany (casing doesn't matter here).
  • Click "More >>" to expand the advanced options.
  • Click the "Replaced what:" box to activate/focus it.
  • Click "Special" button, and choose "Clipboard contents" (this will put ^c in the Replace box).
  • Click "Replace All".
6
  • 3
    That comment about leaving proofing until after writing and editing should be pasted on everyone's monitor. Sep 30, 2016 at 16:14
  • 2
    I believe that Word will still give you a grammar warning if you turn off the auto-correction. So you will still notice when you mistakenly start a sentence with another word without capitalizing.
    – jpmc26
    Sep 30, 2016 at 19:34
  • 1
    -1 for stating "you need to disable that feature for all words." well, no, you don't need to. that's one possible solution, but neither the only or the best one
    – user201265
    Sep 30, 2016 at 22:15
  • @vaxquis so the answer is worth a downvote just because that one statement? Nice logic. Sep 30, 2016 at 23:08
  • 1
    @vaxquis I'm not sure how a viable solution to the problem at hand makes it "useless", but if you feel there are facts that need correcting, feel free to submit an edit. Oct 1, 2016 at 0:18
4

Options -> Proofing -> Auto-Correct Option then un-check "Capitalize first letters of sentences.

Unfortunately this applies to all words that start sentences, but it is the only way I know of preventing this.

This is because in this case it is not being capitalised because it is "my" but because it starts a sentence - and Word believes that sentences either start with a capital letter or they do not. It does not allow finer grained control than this AFAIK.

2

Alternatively, you could wait until you are done with the whole document, then do a case sensitive find & replace Mycompanymycompany just before distributing the document.

I know that, strictly speaking, it's not what you're asking for in OP. But it seems to solve the problem quite well.

However, if the name of your company is also a normal word in the language you're typing in, then that would also be a problem if some sentences started with that word.

8
  • 1
    you could also do a case-insensitive search and just brute-force everything to lowercase. this has the added benefit of showing the computer who's boss and also catching other typos like myCompany.
    – mendota
    Oct 2, 2016 at 0:42
  • Actually, I just realized that [Mm][Yy][Cc]ompany ⇒ mycompany (in wildcard mode) will work — but it doesn't accept [Mm][Yy][Cc][Oo][Mm][Pp][Aa][Nn][Yy], saying that it is "too complex".
    – Scott
    Oct 2, 2016 at 8:35
  • @mendota You know, after testing this in Word 2011, it turns out it actually has to be case sensitive. Regarding showing the computer who's boss: Totally agree. The computer shouldn't get any ideas. Asimov's second law.
    – Fiksdal
    Oct 2, 2016 at 8:37
  • @Scott I'm not exactly sure what you mean by that, but it sounds confusing.
    – Fiksdal
    Oct 2, 2016 at 8:41
  • @Fiksdal Are you familiar with wildcards? *.txt means any name ending with .txt. * matches any string, so cat*ar matches caterpillar. [aeiou] matches a, e, i, o or u; and [Aa] matches A or a — so [Cc][Aa][Tt] matches cat, caT, cAt, cAT, Cat, CaT, CAt or CAT. It’s a gimmick for doing case-insensitive searches. (It can be useful to make only part of a search string case-insensitive; e.g., [Ii]Phone or VM[wW]are.) Microsoft Word’s Search function supports a “Use wildcards” mode — it’s the second checkbox below “Match case”. Are you still confused?
    – Scott
    Oct 2, 2016 at 18:34
0

I found the solution to this dilemma! Just like SuperUser recommended: in Microsoft Word click file; options; proofing; autocorrect; then under 'replace text as you type' enter the word using lowercase letters in both boxes, i.e. mycompany my company

I have been trying to figure this out myself when using doi:, which is not capitalized in apa formatting, and this method worked for me. I hope it works for you as well!

1
  • 1
    Welcome to Super User! Please don't post an answer to confirm that another answer worked. The site's Q&A format reserves answers for solutions to the question, and each answer should contribute another solution. The way to indicate that an answer was useful is to invest a little time in the site and you will gain sufficient privileges to upvote answers you like.
    – fixer1234
    Mar 25, 2018 at 1:01
-5

I think you need to add it to your dictionary for it to ignore it. That should class it as a specific word/term at least. Make sure you type it out and alter the case if Word changes it. Then (assuming you have the red line error) right click and select Add to Dictionary.

I used Word 2013 in my example but it's the same method for 2007 and 2010 versions in case you're not using 2013.

Click here to see the picture attachment

1
  • 9
    This method still capitalizes the m on 'mycompany' at the start of a sentence. Sep 30, 2016 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.