I have Windows 7 Pro 32 bits, attempting to copy large files (over 1 GB) from one of my external USB drives to another does not work. Same thing from the USB drive to the pc drive. The file transfer starts and then quickly slows down to a crawl and then sits there for hours.

Files less than 1 GB transfer fine. With or without my antivirus, no difference. I've also tried disabling remote differential compression, no change either. And ditto for TeraCopy, same exact thing.

Any ideas?


I have the same issue with network drives.

I have tried MANY things, however, unfortunately I was unable to find a resolution using Windows Explorer / GUI.

The two solutions I came up with in the end were either to use the command prompt which worked very well - just a little annoying, and in the end I settled with (Teracopy, available on Ninite for easy installation).

With Teracopy, I find that it takes a little longer to start (talking ~1-2 seconds) which is annoying with small files where Windows would be instant (and 95% of my file operations), however, on large files or when using a lot of little files, it is a brilliant tool with many advantages over the standard Windows GUI. For this reason, I do no use it as the default file copy, but when doing large or complex operations, I always use it.

  • @Wil @Molly Right. Can the two of you please take your issues with each other offline. This is a question and answer site You both have more then enough reputation, so just leave both answers and deal with whatever the votes say. I have deleted this whole conversation since it distract from the question. – BinaryMisfit Feb 24 '10 at 22:46
  • @Diago - it is (or used to be) pretty much etiquette around here (or so i thought) that duplicate answers are deleted by the poster who is late. There is a strong policy against duplicate questions as there used to be against duplicate answers, how do you expect newcomers to learn this if someone with 31k reputation doesn't care for the basic decencies. And this certainly isn't a one-time faux pas on Wil's behalf, he is doing it repeatedly and when someone is pointing it out he resorts to calling these people 'hypocrites'. – Molly7244 Feb 25 '10 at 3:07

I wonder if this is hardware or software? What about trying the same thing using a Linux Live CD (such as Ubuntu 9.10)?

If you get the same thing it must be hardware. Cabling? Bad USB socket(s)? Bad sectors on hard drive? How much free space does the destination drive have? What about checking your hard disk out (e.g. Hard Disk Sentinel)?

If not hardware, then something in Windows 7 is amiss. I wonder if you can replicate the issue in Safe Mode? Didn't Vista have a problem with large file copying? Is this a similar issue? (Sorry never used Vista and only just starting out with Windows 7.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.