0

I have an ASUS Laptop and recently installed Ubuntu 16.04 LTS as dual-boot alongside my Windows 10. Grub and booting between those two worked without any issues. Today I started the Windows 10 Anniversary Update and hell began.

As you might know, after some time the update process enters the stage where the computer gets restarted several times. I left the laptop alone during the update, and when I came back the screen was just on and nothing was displayed. I left it for a long time until I got impatient and closed the lid: I expected just the screen to turn off, but instead when I re-opened it immediately after, a BSOD with Driver Power State Failure appeared (it was a new kind of Windows blue screen since it had a QR-Code on it; so probably from the update). It did a restart and instead of Grub the ASUS logo appeared. After some time the loading circle also appeared. But no hard-drive activity. I left it there for some time until I forced it to shut down and restarted it. In the past I once had this loading issue and a force shutdown and restart did it. But this time it did not help: after selecting Windows in Grub, the same thing happened: ASUS logo, loading circle, no hard-drive activity, forever... I did it several times, but no luck...

Then I tried booting into Ubuntu: it worked like a charm! While in Ubuntu I looked inside my Windows partition, but I could not find any of my personal files; only the Windows files and folders showed up. Luckily there was a Windows.old folder where I could find my recent files.

The next thing I did in Ubuntu was installing Boot-repair and running it with the recommended settings (Paste-bin: http://paste2.org/tEH5bjBF). I restarted and now Grub showed me more Options for Windows:

  • Windows UEFI bootmgfw.efi
  • Windows Boot UEFI loader
  • Windows Boot Manager (on /dev/sda1) (this was previously the only one)
  • And another Windows one containing something with "64" and "uefi" (sorry, I don't remember exactly)

But neither of them seemed to work. Each one of them showed the ASUS logo and then stuck there forever like I described above. Ubuntu still worked.

Then I went to another computer and created a bootable Windows 10 USB drive by downloading the Windows 10 ISO with the Media Creation Tool and then flashing it to a USB stick using rufus. I was hoping to being able to repair Windows by booting from the USB drive so I plugged it in, changed boot order in UEFI and restarted. Then again: ASUS logo, forever... I left it there for about 40(!) minutes and still nothing happened.

I then created a bootable Ubuntu USB drive and tried booting from it: it worked! I could try Ubuntu and everything worked.

What probably has happened to my Windows 10 during the update and what else can I do to successfully boot into Windows again? Usually the Automatic repair appears when something went wrong during an update, but in my case it sadly did not. And why the heck I can't boot from the Windows 10 USB drive?! My last hope was to completely reinstall Windows, but when I can't even boot from a Windows 10 USB drive I'm lost...

0

The most recent windows updates caused havoc with a number of drivers, in your case, I think the USB drivers may have gotten borked. Easiest way to check is to disconnect all connected devices (sans power cable) and reboot the machine (or disconnect during a stage in the boot process where it boots to windows. That seems to fix this problem in most cases.

edit 1: forgot to add, after you get a successful boot to win10, you can reconnect all the devices and resume normal functions.

  • I disconnected my USB mouse and my USB keyboard. The problem persists: ASUS logo with spinning circle and no hard-drive activity :( – Kittion Oct 1 '16 at 8:43
0

I finally fixed it by uninstalling Ubuntu:

  1. I booted from the Ubuntu live USB stick and installed and run OS-Uninstaller. I uninstalled the installed Ubuntu. After a restart grub was still there, but it didn't look like normal, instead it more looked like a terminal and I could not choose between any OSs.
  2. I again booted into the live Ubuntu and run GParted. I deleted the Linux partition and the Linux swap partition as well as another partition called "Restore" (I don't know if it belonged to Ubuntu or Windows, since there was another partition called "Recovery" which was marked as Windows). All three partitions however were behind each other. I then merged the unallocated partitions back into my big DATA partition (D:).
  3. Next I went into UEFI and changed boot order. There still was an boot option called "ubuntu...", I believe this was grub. I put Windows Boot Manager to the top and restarted.

It worked! ASUS logo came, but shortly after the Windows Update continued at 32% percent. Seems like it returned right to the point where my computer crashed. The update finished and I can finally boot normally into Windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.