7

This has become more of an issue since I got a Magic Mouse and have middle-click mapped as 3-finger touch. It's always annoyed me that Firefox even does this--is there a way to prevent firefox from closing tabs when you middle-click them?

5

As there doesn't appear to be a setting in about:config, the only way i know how to do it is using the addon Tab Mix Plus: https://addons.mozilla.org/en-US/firefox/addon/1122

  • that looks to be uber-overkill for the one thing I want to do, but thanks for the suggestion. – Brade Feb 26 '10 at 19:56
  • 2
    Tab Mix Plus appears to have ceased development after Firefox Quantum. Is there another solution now? – Josip Rodin Nov 27 '18 at 11:45
0

It is a system setting not Firefox. You can check on the file explorer.

On Ubuntu 18 gnome : gnome-tweaks > Windows > Titlebar Actions > Middle-Click > select Toggle Maximize

On other system : gsettings command line here: https://askubuntu.com/a/655648/360110

  • I believe the question is about browser tabs, not Gnome windows. – hackerb9 Jun 30 '19 at 4:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.