Recently I moved and set up a new Ethernet network for my home. I have a router feeding into a 16-port gigabit switch, which splits up to the different rooms in the house. In one of the rooms there's a need for multiple ports so I have the mentioned 8-port D-Link switch.

Before the move it worked just fine, but now when I plug a cable from the wall (meaning from the 16-port main switch) to the secondary switch, it does not recognize the connection at all (no light). When I plug a computer to said switch, an orange light lights up (LAN connection, no internet). The connection to the main switch is working - when I plug a computer directly to it I have a perfectly working connection.

I should mention that the network in the walls is a CAT6 type, but it doesn't work when I use CAT6 or CAT5 cables with the secondary switch, and I have tried a power cycle with the secondary switch.

Thanks for any help.

EDIT: I did a bit of tinkering, and found out that the secondary switch works when:

  • Connected directly to the main switch
  • Connected the wall port through a third switch

This is getting weird. This implies some issue in the connection of the switch to the wall port, but I know both are working (and switching cables didn't help...)

EDIT 2: As I continue to mess around, I thought the problem is simply with the wall port, but using a PoE injector (with no DC voltage) as a middleman between the port and the switch did not work.


DGS-1008a is a Fast Ethernet Switch. Fast Ethernet does not have Auto-MDIX, which would swap pins if a crossover cable would be needed where a straight cable is installed, or vice versa.

If the other switch also hasn't Auto-MDIX, they cannot connect if the wrong cable is used, or the cable is falsely connected to the sockets in your wall installed in your wall.

Your computer very likely has a GBE port. The have become standard years ago. Your computer is therefore able to switch pins if needed.

What is the 16port switch? It is a GBE switch, thus it should have Auto-MDIX, but maybe it doesn't.

Try a crossover cable between wall socket and DGS switch.

| improve this answer | |
  • This is interesting. I did not consider the option that the cable's jack isn't climped correctly. Is there a way to check which wires are misplaced? How will I know what crossover cable to get? – ScubaDiving Oct 7 '16 at 16:15
  • 1
    The 16-port switch is a TP-LINK TL-SG1016D and it has auto-MDIX. @Tobias Knauss – ScubaDiving Oct 7 '16 at 16:29
  • 1) Did you test Laptop to 16port switch with the wall's cable in between or with a patch cable? If it was with the wall's cable and you got a Gigabit connection, then the socket is fine. 2) Did you try in other rooms? Did you test on different ports of each switch? 3) there is only on type of crossover cable. But here you don't need it due to Auto-MDIX. – Tobias Knauss Oct 7 '16 at 16:44
  • 1. I got a connection with a laptop from the wall socket with a regular cable. 2. The switch works in other rooms. 3. I tried to move the cable of the wall socket to other ports on the 16-port switch but it didn't help. – ScubaDiving Oct 7 '16 at 16:50
  • This sounds weird. Your laptop is working on the wall socket, but the DGS switch isn't, although the same switch is working in other rooms. My conclusion is that there's something wrong with either one of the 2 sockets or the cable in the wall. Fast Ethernet (FE) uses pins 1,2,3,6 only, thus 2 of 4 pairs. GBE uses all pairs. If GBE has a connection, then FE must work also. Except GBE had a fallback method to use the other two pairs, which I doubt and I've never heard of. Anyway, check the sockets by disassembling them. If they're fine: did you recently put a nail or screw hole into the wall? – Tobias Knauss Oct 7 '16 at 17:01

Well, this is by no means a solution, but this is what I did to bypass the problem, in order to avoid using really old hardware instead of the one I have or buying a new one, which are possibilities that probably most people will prefer.

Basically, I just plugged in a WiFi USB stick into the PC that I have sitting in that room and ran a bridge between the WiFi Network and the Ethernet port of the computer. Then, I just connected my DGS Switch to the Ethernet port and after setting a static IP it worked. The wall port is used for the WiFi Access Point, which is so close to the USB stick that the delay isn't really noticeable.

A better variation of this will be to use a USB-LAN adapter, or even better - a PCI GBE Network Card, but these required too much work or parts I don't have so I just went with what I had.

EDIT: I bought a new switch and it works perfectly.

| improve this answer | |

It could've been an issue with amount of connected wires, ie 4 instead of 8. Had the same issue with DGS-1100-05 - pc works fine through outlet while switch doesn't. Making sure that there were 8 wires connected on both sides of the outlet resolved the problem for me.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.