32

Gparted shows mu such a message after scanning the disk contents with title "Libprated warning".

The background:

This happened after I tried shrinking down one of the partitions to make room for another partition. I was doing this with The KDE Partition Manager. It's a brand new machine, but somehow things has gone wrong and I was unable to mount the down-sized partition.

I recovered the partition table with TestDisk, but the system seemed to hand in the Plymouth after showing an error message about the swap partition (which was under sda1).

Now've booted a LiveCD and I can mount and browse both the system and data partition. I created a new swap.

What can I do to fix this issue? And what problems might this cause?

5
  • I've shrunken the partition and added a new one as I wanted, rebooted the machine, and all seems to work fine now. I've run Gparted and it didn't rise it's warning about block size again.
    – unfa
    Oct 3, 2016 at 13:05
  • I've got this issue again - it turned out it was in relation to a pendrive - the message that Gparted displays doesn't tell what device this issue is about.
    – unfa
    Dec 17, 2016 at 22:07
  • It does tell you which device the issue is about. When the error requester pops up, look in the lower left corner of the main GParted window. There it reads "Searching /dev/sdX partitions", with "sdX" referring to the faulty device. (Took me a couple of attempts to realize that, for me as well, the issue wasn't any of my HD's, but the USB stick I booted the LiveISO from...)
    – DevSolar
    Jan 27, 2017 at 12:51
  • Would I need to resolve this issue before resizing the partitioning in question?
    – Merchako
    Jun 13, 2017 at 17:04
  • I've realized that the problem is only happening for USB Flash memory, but Gparted doesn't say which drive is affected by the bad reported sector size.
    – unfa
    Feb 13, 2018 at 13:59

3 Answers 3

31

The issue is very similar to the one below, most likely there was a dd command ran over the device that caused the mismatch descriptor.

Ask Ubuntu: Unable to delete USB Drive partitions (Block size error)

The problem you are describing was caused by a low-level device tool (like dd) writing blocks at the wrong size directly onto the device.

To fix this, you need to re-write the device blocks to the appropriate size. This can be done with dd. Double check your output device before running the commands:

sudo dd if=/dev/zero of=/dev/sdd bs=2048 count=32 && sync

Once the dd command is done, you should be able to access your device through gparted.

6
  • You should quote and cite the relevant information from the linked question.
    – Ramhound
    Dec 5, 2016 at 18:32
  • Doesn't seem to help.
    – ulidtko
    Jun 9, 2017 at 13:16
  • 7
    downvoted -1 ; @ulidtko, of course it does not help. I really don't understand why this was upvoted, (maybe lemmings ?...). The answer is wrong. 'bs=2048' in 'dd' cmd does NOT make the block size 2048 B. In other words "bs" does not mean "block size" but "buffer size". What this cmd does very well though, is buffering at most 2048 B at a time when writing to the 'of' block volume. The blocks in the volume are not changed in any way though.
    – Cbhihe
    Oct 7, 2017 at 10:38
  • 1
    the responder doesn't seem to know what he's talking about, this doesn't solve the issue. After this I ran into other error messages when trying to delete partitions on the device. Getting deeper into trouble, don't use this command! Jul 28, 2018 at 13:19
  • 1
    despite hatoful anti lemmings: this indeed worked for me
    – krysopath
    Nov 10, 2018 at 12:17
9

I don't want to steal someone else's work; the original contributor is Damiön la Bagh here: https://bugs.launchpad.net/ubuntu/+source/usb-creator/+bug/1708881

Be warned that by performing this procedure you will lose the data you have on your drive. When successful, you will end up with a usable drive, but no attempt is made here at recovering data from it.

Identify your USB drive's letter, then issue the command:

sudo wipefs --all /dev/sdN  

(replace N with your disks's drive letter; this command should complete instantly.)

Launch gparted now; select the USB stick, which will appear empty. You'll first have to create a new partition table (Device > Create partition table). If you're unsure you can choose 'msdos'. This should also complete in a second. Then you'll be able to create new partitions as usual.

5
  • Tried this for my hard disk but the problem still persists.
    – Nav
    May 28, 2019 at 1:31
  • THIS WILL ERASE ALL YOUR DATA. Just leaving that here so that someone doesn't accidentally run the wrong command
    – benathon
    Feb 11, 2020 at 4:50
  • 1
    @portforwardpodcast thanks, I added a warning. Didn't think about it because, well, it's the natural consequence of creating a new partition table. It's there now though.
    – Roberto
    Feb 14, 2020 at 14:22
  • Good. My warning was just trying to make the internet a safer place
    – benathon
    Feb 14, 2020 at 20:16
  • 2
    This worked for me. Apr 5, 2020 at 20:20
-2

Instead of the bs parameter it needs the obs parameter. From dd --help:

obs=BYTES       write BYTES bytes at a time (default: 512)

The command would be something like:

sudo dd if=/dev/zero of=/dev/sdd obs=2048 count=32 && sync
2
  • This seems to be a comment on the answer by LitmusD. If you intend it to be an answer to the question, please edit it so that it makes sense to someone who has only read the question.
    – Blackwood
    Dec 15, 2017 at 18:04
  • dd --help also says “bs= BYTES       read and write up to BYTES bytes at a time”.  And dd(1) says “bs= BYTES       read and write up to BYTES bytes at a time (default: 512); overrides ibs and obs” (emphasis added). So specifying bs alone should be just fine. Dec 15, 2017 at 18:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.