13

Windows 10 wakes randomly after putting it to sleep.

I have tried all proposed solutions from this old question: I have added a disable flag for the automatic maintenance in the registry, disabled the Media Center update scheduled task, disabled "wake on x" on my network adapter, disallowed scheduled maintenance tasks to wake in Security and Maintenance, and disallowed wake timers in the Power Options.

The Event Viewer lists Wake Source: Unknown for all random wake events.

After querying for wake timers I get: enter image description here

I'm assuming this is the culprit. How do I disable it?

EDIT: This problem subsided after all the steps above, but now reoccurs for me again (presumably due to an update). I've just done the following steps that might help: First, Open the "Task Scheduler" and go into the tree as follows: Microsoft\Windows\UpdateOrchestrator\Reboot. Rightclick -> Properties -> Conditions -> Uncheck "Wake the computer to run this task". Second, change registry entry hkey_local_machine\software\Microsoft\Windows NT\CurrentVersion\WinLogon\PowerdownAfterShutdown to 1.

1
  • Without giving the Windows version (Win 10, ver 1703, etc.) answers that list how to find a setting are well intentioned but often unhelpful, because MS keeps changing their location, even eliminates them.
    – Bilateral
    Jan 28, 2018 at 7:32

3 Answers 3

14

The first step is to deactivate Wake Timers in your power saving profile. To do this, go to PowerOptions > Advanced Settings > Sleep > Allow Wake Timers > Setting: Disabled.

Next go to Control Panel > System and Security > Security and Maintenance > expand Maintenance section > click on Change maintenance settings. Uncheck the option that allows the PC to wake up. You may need to change the time first, or the option will stay unchecked but the task will remain armed. This may not happen, but it is possible.

This will disable the Maintenance Activator. If this does not work, there is another fix.

First, open Regedit. Then navigate to the following registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\Maintenance. If this doesn't exist, create it. Create a 32 bit DWORD value named MaintenanceDisabled, if it is not already there. Set it to 1. Then reboot your computer. This will disable the automatic maintenance.

6
  • Thanks for the answer. Both these options were already tried, however. From my original post body: "disallowed scheduled maintenance tasks to wake in Security and Maintenance, and disallowed wake timers in the Power Options" Jun 30, 2017 at 5:49
  • A recent update made the problem reappear for me. I just opened the "Task Scheduler" and went into the tree as follows: Microsoft\Windows\UpdateOrchestrator\Reboot. Rightclick -> Properties -> Conditions -> Uncheck "Wake the computer to run this task". Hopefully this will work. Nov 8, 2017 at 20:31
  • I also just set (=1) this reg entry via some MS thread hkey_local_machine\software\Microsoft\Windows NT\CurrentVersion\WinLogon\PowerdownAfterShutdown Nov 8, 2017 at 20:52
  • With the box unticked, I changed my time, even rebooted, and the timer remained armed. To properly unarm it, I had to retick the box, click OK, then untick the box. At that point, powercfg /waketimers reports that there are no active wake timers.
    – drglove
    Feb 3, 2018 at 20:11
  • Follow the instructions pertaining to the registry, this should solve it for you if you still have the problem. Jun 28, 2018 at 18:54
1

This worked for me:

Configure power options > Advanced settings > Hibernate > Allow activation timers > "Setting: Disable" > Apply > OK

And that's it!    

0
1

Anyone still having this problem should try these steps:

  1. Open Group Policy Editor (gpedit.msc)
  2. In the left pane avigate to Computer Configuration > Administrative Templates > Windows Components > Windows Update
  3. In the right pane find and double-click Enabling Windows Update Power Management to automatically wake up the system to install scheduled updates option
  4. In the popup window that opens change selected radio button from Not Configured to Disabled
  5. Click on OK button, and close the Group Policy Editor

If your Windows edition doesn't have Group Policy Editor, you can do the same via the registry by running the following command from the Administrator command prompt:

reg add "HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate" /v "AUPowerManagement" /t REG_DWORD /d 0 /f

Microsoft deciding to exempt Update Orchestrator service from the wake timers power setting is another proof of their arrogance and disrespect for their customers.

1
  • An important note: the Group Policy Editor is not installed on the Home and Student editions of Windows 10 or 11. It's technically possible to install it, but many updates breaks it up and requires new files now and then. (Microsoft doesn't want to allow the Home or Student editions to have gpedit.msc because it allows the user to disable anything the OS has, including what's set by default.) Apr 13 at 2:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .