3

When I hit the arrow keys in insert mode I get characters instead of navigation:

Pressing arrow keys types characters

I'd like to be able to use the arrow keys to navigate.

Note:

I recently upgraded to macOS Sierra. Maybe something about the terminal changed, because that must have been about the time this problem started.


Things I've tried

I have set nocompatible in my ~/.vimrc (vimrc pastebin), I am using pathogen and here is my ~/.vim/bundle directory:

YouCompleteMe/
emmet-vim/
nerdtree/
node/
vim-airline/
vim-markdown/

The problem only started recently, can't remember the cause.

Some recommend :set term=builtin_ansi, and this fixes the problem but removes all my colors.


$ vim --version
VIM - Vi IMproved 7.4 (2013 Aug 10, compiled Aug 29 2016 12:51:13)
MacOS X (unix) version
Included patches: 1-2290
Compiled by Homebrew
Huge version without GUI.  Features included (+) or not (-):
...

See http://pastebin.com/5z1HbpqW for the whole output.

$ echo $TERM
xterm-256color

and in vim:

:set compatible?
nocompatible

:set term?
term=xterm-256color
  • There are many proposed fixes on the Vim Tips Wiki. – Deltik Oct 4 '16 at 16:23
  • @Deltik I know, none of them worked for me. – theonlygusti Oct 4 '16 at 16:26
  • In the article you link to, in "Solution 5" it says that nocompatible is the default. Did you try setting it to compatible? – Andrew Morton Oct 4 '16 at 18:25
  • Looks like your TTimeoutLen is set to 10 in your vimrc file. Try upping that to like 1000 and see if that makes a difference. – Ƭᴇcʜιᴇ007 Oct 4 '16 at 19:59
  • @Ƭᴇcʜιᴇ007 how? :set TTimeoutLen says no such option – theonlygusti Oct 4 '16 at 20:01
1

I had the same problems on multiple ubutnu machines (16.04 LTS). And none of the soultions worked for me, but then i just did one easy thing. I updated vim via sudo apt-get update sudo apt-get install vim and voila, it worked.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.