I am trying to create a custom bootable CentOS 7 ISO that boots from USB.

  1. I have downloaded the CentOS minimal DVD
  2. I have used dd to put the ISO onto the thumbdrive:

    dd if=CentOS-7-x86_64-Minimal-1511.iso of=/dev/sdb bs=4MB
  3. I have tried multiple options to boot from DVD like changing boot order and disabling/enabling UEFI bios but it just does not boot from the thumb drive. The ISO works fine if I burn it to DVD.

What can I do to get it to boot?

  • Using dd will work only if you start with a hybrid ISO. Some explanation here that may be helpful: Make Live USB flash drive with dd – fixer1234 Oct 4 '16 at 21:42
  • Thanks Fixer, your comment put me in the right direction: It was a custom ISO and I was running isohybrid but because of a variable scope change, the parameter to the file name had an empty value (variable scope). I tried to upvote the answer on the page linked but I did not have enough points for it to make a difference but I would accept your comment if it was an answer. – Youn EA Oct 5 '16 at 15:01
  • Glad the other thread suggested a good direction, but it sounds like your actual problem was something different. Consider posting your own answer. That could help others with a similar problem. – fixer1234 Oct 5 '16 at 15:08

This process depends on the make, model, and BIOS version of the PC you are starting. For instance, on a HP Pro 6200 MT, I have to press Escape on startup in order to choose my startup disk. On many Dells, I have to press F12. The BIOS version matters - old ones may not support UEFI.

  • I did try to set the boot order both in the bios and with one time boot menu. The PC is an HP server manufactured last year so it does support USB boot. – Youn EA Oct 4 '16 at 21:32
  • Good. Check the HP website for the latest BIOS version, and see if you can update the BIOS in the server. It may have shipped to you on an old BIOS version. It's also possible that the "burn" to the USB stick wasn't perfect - try making another one. It's also possible that USB 3.0 ports aren't available for booting - I've had that problem on desktop machines - try another USB port explicitly low speed. – Christopher Hostage Oct 4 '16 at 21:35
  • 1
    Thanks for the suggestion, I eventually figured it out, my isohybrid was had a wrong parameter. – Youn EA Oct 5 '16 at 15:02

In this instance, I would recommend using a tool such as Rufus (if you have a Windows computer available) to "burn" the image to your USB drive. I typically use that when a direct-write doesn't appear to be working, often with success.

In your case, I believe the issue is similar to that of this previously noted issue.

  • Sounds like he's on Linux, in that case Unetbootin would work (should be in repos in just about any distro). – Dylan Knoll Oct 4 '16 at 23:08
  • Indeed, I am on linux. I was trying to use dd so the process can be automated. Figured my isohybrid command was running with an empty parameter. – Youn EA Oct 5 '16 at 14:56

When generating a custom centos ISO, to get it to boot in a usb stick, isohybrid required.

In my case I was using isohybrid but I the variable I was using as the iso path was wrong. As a result isohybrid was failing


When I first installed the (centos DVD) ISO on my usb device I formatted the drive as ext4 - I never had an issues with any other linux iso before centos.

I reformatted my usb device as FAT32 and centos started up with no issues.

Check your formatting of the drive.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.