2

I am trying to run Windows Update on a fresh VM using VirtualBox, but the Windows Update keeps hanging on "Checking for updates..."

Host OS: macOS Guest OS: Windows Embedded 8.1 Industry Pro

Happy to provide any other details necessary to help solve this problem. I have gone through several troubleshooting steps already and had no luck, including repairing the update services.

closed as too broad by Ramhound, DavidPostill, techraf, mdpc, Moses Oct 6 '16 at 17:31

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

0

Stop the Windows Update Service (via services.msc or in a cmd.exe which is started as admin via net stop wuauserv - this improves speed of installing the MSU update which you have to download), download and install this update by double click on the MSU:

Installing and searching for updates is slow and high CPU usage occurs in Windows 8.1

Do a reboot and check again for new updates. Now Windows Update will work and show new updates in a few minutes.

1

The solution was found on a forum:

  • Disable "Install updates automatically (recommended)". Set it to "Never check for updates (not recommended). Restart PC
  • Download KB3138615 from microsoft and install it. Restart PC
  • Download KB3172614 from microsoft and install it. Restart PC

Now you can check for updates and install the most recent update using Windows Update. You can also enable "Install updates automatically (recommended)"

  • This is the answer that has worked for me in several situations where I upgraded from Windows 8 to Windows 8.1. More recently, the sequence of updates should be KB3173424 then KB3172614. – vallismortis Jul 22 at 23:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.