32

I'm not sure what I pressed or clicked but I can no longer see the taskbar in KDE. I'm not finding any desktop switching keys though ALT+Tab still switches to already opened windows. Right-clicking on the blank empty black background does nothing. On Windows 7 I'd just CTRL+ALT+Delete, kill explorer.exe and start explorer again.

How do I show the missing taskbar in KDE?

4
  • I think maybe your KDE silently died and left you with bare X server and your open windows. Did you try to restart the whole system? Oct 5, 2016 at 14:08
  • @KamilMaciorowski Yeah but it happened again. :-\
    – John
    Oct 5, 2016 at 14:15
  • Was there graphical login prompt? After login, did KDE interface appear (if only for a moment) or not? Oct 5, 2016 at 14:21
  • @KamilMaciorowski Either it crashed without a crash message or I either pressed a button or clicked my mouse and inadvertently screwed it up.
    – John
    Oct 5, 2016 at 14:38

5 Answers 5

39

Killing the plasmashell process and restarting it from a terminal helped me in this situation.

To terminate the plasmashell process you will need access to a terminal. On most distributions you can get a terminal with CTRL+ALT+F1 or CTRL+ALT+F2. Don't worry, your screen will turn black and you will be prompted to log in with your username and password.

To get back to your regular KDE session you will need to press CTRL+ALT+F7 or CTRL+ALT+F1!

Once you have opened a terminal session you can stop the plasmashell process with

killall plasmashell

and start it again with

plasmashell &

The & is only required if you want to be able to close the terminal or want to be able to keep using it for other commands. It will start the plasmashell process in the background so it does not close with the terminal and does not keep blocking the terminal from receiving further input.

Alternatively you can kill the plasmashell process in your terminal and then immediately return to KDE and hit your hotkey for krunner, which is afaik ALT+F2 by default, and enter plasmashell there.

7
  • ...I probably did not accept this answer because it lacked/lacks instructions. If someone is asking a question an answer should provide instructions.
    – John
    Sep 7, 2018 at 9:55
  • 1
    That can be fixed :)
    – FlyingFoX
    Sep 11, 2018 at 16:17
  • Thank you, I up-voted this, looks legitimate though since I'm no longer running that environment I can't technically accept it...right now. It might be a year down the line though with Microsoft busy destroying the parts of Windows that actually still works I'll eventually find some time to explore a hopefully even more matured Linux OS. KDE has been my preferred desktop environment.
    – John
    Sep 12, 2018 at 12:57
  • I've stumbled upon a very similar phenomenon, but restarting plasmashell in a shell alone was enough, so this process crashed somehow before. Maybe there is a bug related to or in VSCode, because its small preview windows become very small before the task bar crashes. This happens when you click on the VSCode entry nonetheless.
    – BairDev
    Nov 30, 2018 at 10:13
  • @John Accept it. It still works! (The answer I mean) Oct 17, 2019 at 7:28
32

In my case the ~/.config/plasma-org.kde.plasma.desktop-appletsrc file got in a bad state (from switching from laptop to external monitor).

Rather than trying to fix the file, I just deleted it (ALT-F2 "konsole"):

rm ~/.config/plasma-org.kde.plasma.desktop-appletsrc

Then logout from the session (ALT-F2 "logout") Log back in, and the taskbar is now visible, some settings were lost (background color, ...)

I now personally keep a backup of the file, in case it happens again:

cp ~/.config/plasma-org.kde.plasma.desktop-appletsrc ~/.config/plasma-org.kde.plasma.desktop-appletsrc.backup
7
  • 3
    First one didn't actually solve the problem, but this one did!
    – Rainb
    Jan 20, 2020 at 16:25
  • Brilliant, thank you! Any tips on how to avoid it happening again?
    – bdeniker
    Jan 24, 2020 at 9:07
  • Reboots, killing plasma shell, etc. didn't work for me either. But this one did for me too :) Thank you!
    – HBSKan
    Mar 21, 2020 at 16:31
  • It worked on Kubuntu 19.10. Thank you
    – Alex Poca
    Apr 10, 2020 at 20:07
  • 2
    I had removed a videocard, going from three to one monitor. This answer gave me a fresh new taskbar, but my menu panel was still gone. What I then did was edit my own file (no, had not deleted it, but moved it out of the way) and ran: sed -i -e 's/^lastScreen=.*/lastScreen=0/' ~/.config/plasma-org.kde.plasma.desktop-appletsrc - then logged out and back in and got everything back as it was.
    – Carlo Wood
    May 7, 2020 at 19:18
2

As I faced exactly the same issue on my notebook with Intel+Nvidia Optimus (proprietary driver), my solution is to add

xrandr --output VGA-0 --off

to /usr/share/sddm/scripts/Xsetup

Though removing ~/.config files is a default reaction, it didn't solve my problem. Anyway I'd recommend renaming configuration files if needed for testing purposes:

mv ~/.config/plasma-org.kde.plasma.desktop-appletsrc ~/.config/plasma-org.kde.plasma.desktop-appletsrc.bkp

It is a known bug that nvidia drivers add CTR device VGA-0 even if it is not connected. So this caused plasmashell to crash at login time. A quite comprehensible reaction to such a noobish bug IMHO.

I also tried to disable VGA-0 in KDE Display Settings, but these settings come into effect after login. Xsetup is run before sddm starts, so the CTR device is disabled even before startplasmashell-X11 which is executed by /usr/share/xsessions/plasma.desktop

Hope this helps to solve it without plasmashell --replace & because that command slows down login time, plus grinded my nerves.

Cheers

1
  • Thanks a lot! Your post was the end to a more-than-one-hour long bughunt! I don't think I would have found the issue without your post!
    – Dakkaron
    Apr 30 at 20:23
0

cmd-->plasma-desktop will restart your kde-plasma without killing existing shell/vim etc.

1
  • 1
    If this was Windows you would be implying holding Starting+R, type cmd, press Enter and then type plasma-desktop. To make your answer worth anyone's time pretend they don't know how to get to the terminal with an empty screen.
    – John
    Oct 3, 2020 at 8:55
0

You can reinstall the plasma-desktop to use KDE again:

sudo apt-get reinstall plasma-desktop

Alternatively you can use the dpkg-reconfigure to reconfig your plasma desktop:

sudo dpkg-reconfigure plasma-desktop

This is a problem for some kde updates.

http://bugs.launchpad.net/ubuntu/+source/kdeadmin/+bug/331192/

Is this OK @Peregrino69? ;‑)

1
  • 1
    Add the link to the answer as well :-) My comment's served its purpose, so I'll delete it now. Sep 26, 2021 at 13:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.