6

My host is 64 bit Windows 7 bit where my VirtualBox is running 32 bit Windows 7. I have installed guest services and I have enabled drag and drop in Settings >> General >> Advance to bidirectional.

I can copy/paste text file between host and virtual box and copy/paste or drag/drop doesn't work.

I have tried one of the solution here by Sam there (Kill VBoxTray.exe) but it didn't work. I see other threads like this but there are no answer.

  • Which version of VirtualBox are you using? Can you drag and drop from the guest VM to the host? – Ƭᴇcʜιᴇ007 Oct 5 '16 at 15:32
  • Also from VBox's documentation (latest version): "Limitations: On Windows hosts, dragging and dropping content from UAC-elevated (User Account Control) programs to non-UAC-elevated programs and vice versa is now allowed. So when starting VirtualBox with Administrator privileges then drag and drop will not work with the Windows Explorer which runs with regular user privileges by default." – Ƭᴇcʜιᴇ007 Oct 5 '16 at 15:40
  • @Ƭᴇcʜιᴇ007 I am using the latest 5.1.6 The drag and drop doesn't work in either direction. – zar Oct 5 '16 at 17:13
  • To install guest services, when your virtual OS is running from Virtual box menu select Devices -> Insert Guest Additions CD image. Guest editions is required to have drag & drop and shared clipboard – mohas Nov 17 '17 at 21:03
4

Open windows explorer as administrator and drag from there:

  • open Windows directory
  • Locate explorer.exe
  • Right click, run as administrator

Tested on 5.1.8, host and guest both windows 7 x64, using guest additions.

Note: You might need to shutdown and start again the guest os, at least for me the guest bugs badly when I try to drag a file from a non UAC explorer window.

  • Awesome, that worked! I also had to reboot my VM to make it work. Before reboot though, copy/paste messed the VM, the explorer on it will not work properly after copy/paste..double click edited folder instead of opening. Reboot fixed those issues. – zar Nov 14 '16 at 21:08
  • And FYI, explorer.exe is typically in C:\Windows – zar Nov 14 '16 at 21:22
  • 1
    It did not work for me. The guest is always stuck with "Dropping data... 0%" – Mert Mertce Jul 18 '18 at 10:21
0

Believe it or not, I solved that problem by installing Virtualbox 5.2 and everything works including drag and drop. It is kind of like Microsoft's presenting Vista which didn't work and everyone going back to 7 or XP. Sometimes an upgrade is not so good and it is best to stick with what you know works. Hope this helps. Richard

New contributor
Richard Sainz is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

protected by Community Oct 12 at 18:03

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.