7

I just upgraded to a new computer (Windows 10). On my old one (also Windows 10) when I remote desktop (full screen, all monitors) to another computer, the connection bar would default to unpinned. It would appear if I hovered at the top of any screen, but otherwise was not visible.

Since my upgrade, my remote desktop session always comes up with the connection bar pinned. I have to manually unpin it every session. I tried changing the hide option, but that just makes it hidden all the time, which is definitely not desirable! How can I get that old behavior of defaulting to unpinned, but show on top of screen hover?

4
  • Are you using mstsc.exe to do remote desktop, or the Microsoft Remote Desktop app from the Microsoft Store?
    – LPChip
    Oct 5 '16 at 14:57
  • There's a different one available on the store? I'm using mstsc.exe, the built-in one, same on both machines. Oct 5 '16 at 14:59
  • Yes, the one in the store is quite different. Works more like one you'd find on a phone or tablet. I think mstsc.exe is still better though.
    – LPChip
    Oct 5 '16 at 15:00
  • 1
    I just tested it on my Windows 10 environment. When I first connect it indeed defaults to pinned. I unpin, move the mouse away so the bar goes away and then close the connection. Next time I connect to that machine, the connection is still unpinned. So it seems to be something on your end, not specifically to windows 10.
    – LPChip
    Oct 5 '16 at 15:04
8

Option 1: Add pinconnectionbar to your .rdp file

Pinconnectionbar

This setting determines whether or not the connection bar should be pinned to the top of the remote session upon connection.

Syntax

pinconnectionbar:i:<value>

Values Values Explanation
0 The connection bar should not be pinned to the top of the remote session.
1 The connection bar should be pinned to the top of the remote session.

https://technet.microsoft.com/en-us/library/ff393714(v=ws.10).aspx

Option 2: Add Value to Registry

In HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client add a DWORD value PinConnectionBar with the same values as above. This option works the first time. However, the Remote Desktop Client deletes the key afterwards.

3
  • While interesting and looking like it should be helpful... No change. No impact either way. I still have a pinned connection bar on every startup whether or not the parameter is in place (with either value). Oct 5 '16 at 15:21
  • 2
    I added pinconnectionbar:i:0 to Documents\Default.rdp (which is a hidden file). The bar was unpinned for :0 and pinned for :1.
    – Steven
    Oct 5 '16 at 15:37
  • 1
    As of Windows 10 version (20H2) dd 26 feb 2021, this doesn't;t seem to work anymore - see my answer belong.
    – R. Hoek
    Feb 26 at 7:58
1

Appears to have been a Windows 10 bug which was later corrected in a cumulative update.

0
1

NOTE: In the 'current' (26 feb 2021) Windows 10 version (20H2) there (again) seems to be a 'bug' with the Remote Desktop Client, which as a result doesn't let it respect the RDP-setting pinconnectionbar:I:<value>.

However, it's still possible to use the registry to unpin the connection bar for ALL RDP-sessions: goto HKCU\Software\Microsoft\Terminal Server Client and add the dword value PinConnectionBar (when it doesn't exist) and set the value to 0 to unpin all (future) remote desktop sessions.

As mentioned in another answer to this post, this key was expected to be removed after closing the session, but since the pinconnectionbar option of the RDP-file no longer works, this option seems to stick in the registry.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.