0

RESOLVED: Rebooted. I was hoping to find out what happened without doing that, but at least it's fixed.

I believe I brushed my keyboard accidentally and now key presses beyond alphanumeric keys are showing in the command line - backspace shows as \[character], Ctrl+[key] shows as ^[key], pressing Delete gives [3~^, etc.

For example, typing "asdf" then backspacing all the characters leaves this on my line: asdf\fdsa/ .

There's also some strange behavior involving the cursor returning to the beginning of the line and overwriting characters - I've togged my Insert key back and forth with no discernable result.

I recognize some of this from The Unix Programming Environment where they talk about paper terminals and control keys, so I understand some of the output and what's going on, but I'd like to return it to normal. I would love to know what exactly would turn it off rather than just doing "reset" - is there some obvious keypress / combination I might have hit?

I've tried to search for this on Google and SE, but the weird escape characters, etc. are making it hard for me to describe the problem and find hits.

Edit: I've tried stty sane; this doesn't seem to do anything; reset doesn't fix it either.

Here's the output of my stty -a:

speed 38400 baud; rows 127; columns 144; line = 0;
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = <undef>;
eol2 = <undef>; swtch = <undef>; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R;
werase = ^W; lnext = ^V; discard = ^O; min = 1; time = 0;
-parenb -parodd -cmspar cs8 -hupcl -cstopb cread -clocal -crtscts
-ignbrk brkint ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff
-iuclc -ixany imaxbel -iutf8
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt
echoctl echoke -flusho -extproc
0

1) At first, i think you'd better asked at: https://askubuntu.com/

2) try to press Ctrl+v, then ENTER. and see what happens - it may change the mode.

3) try running stty sane

4) if not helps, view the similar topic - source: https://askubuntu.com/questions/441744/pressing-enter-produces-m-instead-of-a-newline

  • Pressing Ctrl + v did nothing; subsequently pressing Enter printed ^M to the line. Pressing Enter again did nothing, and didn't change the behavior. – ModelHX Oct 5 '16 at 18:59
  • I have updated answer, see it again. – T.Todua Oct 5 '16 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.