1

I tried converting my system disk from MBR to UEFI with gptgen. It said it was successful but now it won't boot back in. Currently in UEFI boot.

Don't have enough Rep to post images but basically fdisk outputs my original windows partitions as Microsoft basic data. Gdisk claims to have found a valid GPT with protective MBR.

I don't have any backups. T.T

Any help would be appreciated.

6
  • If you have no backups there isn't a solution to your problem – Ramhound Oct 6 '16 at 1:59
  • Perhaps any recovery tools I can use? – Jaden Wang Oct 6 '16 at 2:01
  • They won't reverse the damage GPTgen has done – Ramhound Oct 6 '16 at 2:03
  • Seems to me like the issue is with the bootloader, not the filesystem. If this is the case, quick! grab your files before you mess something up! Boot to a linux live cd and copy your files to an external drive or something. As for the bootloader, have you tried switching to legacy? GPT is likely not UEFI-compatible, and even then, i'm not sure how that works when booting to a UEFI OS – Blaine Oct 6 '16 at 4:23
  • 2
    @Blaine I believe GPT is UEFI-compatible. The windows 10 install media even allows you to choose between GPT or MBR. – cascer1 Oct 6 '16 at 11:38
2

I fixed it. I was correct to assume that data had just been untouched. I just had to modify the boot partition so that it was compatible with my new UEFI.

I followed the resources available here: http://social.technet.microsoft.com/wiki/contents/articles/14286.converting-windows-bios-installation-to-uefi.aspx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.