0

I have a laptop that I've setup with a separate admin and standard user account. When trying to access the standard users user folder from the administrators account to run a program from the downloads folder it says that I don't currently have permission.

Under the Security tab of the folder it says I must have read permissions to view the properties of the folder. Under the advanced settings it's clear that the administrators user name doesn't have any permissions to the folder. Why would the administrator be missing permissions to this folder? Is this abnormal?

Can I have help in granting/repairing the permissions?

1

If this was initially created as a Roaming Profile the c:\Users\%username%\ folder will only be readable by the User of the profile.

By default administrators do not have control of the user’s roaming profile.

To workaround this behavior, you may consider creating the user profile folder with the Administrators full control permissions ahead of time that the user upload their roaming profile into the shared folder on server.

If we want to apply "Administrators" rights to the user’s roaming folder after they have been initialized by the users, we may have to take the ownership of the roaming folder by administrator, and then grant the "Administrators" right on roaming profile folder.

Take ownership of folder

Takeown /f /a

Grant a folder with Administrator full control permission

icacls /grant "domainname\Administrators:(F)"

For more information, please refer to:

To work around this behavior, create the user profile folder ahead of time with the Roaming Profile Folders Do Not Allow Administrative Access http://support.microsoft.com/kb/222043

  • Hi and thanks for your reply. How would I know if the user folder is a Roaming profile and why would it have been created as one if it is? Is it possible to convert it into a normal user profile? Perhaps before we go ahead with the workaround we should first determine that it is a Roaming profile? – Kol12 Oct 6 '16 at 3:03
  • Ok I had a look under advanced system settings/user profiles and the user is listed as having a local account. Does that mean that they don't have a Roaming profile or is it the actual user folder that can have a Roaming profile rather than their whole account? – Kol12 Oct 6 '16 at 3:12
  • Advanced system settings/user profiles will definitely tell you the type of profile. I've seen non-Roaming with the same permissions set to only user has access to their profile. If you want access to user profiles and are part of the Administrators group you can using Security | Advanced: 1) Take ownership (probably from SYSTEM) with Replace all child object permissions enabled. 2) Close and reopen dialog. 3) Then Add Full Control permissions back for: SYSTEM, Administrators, and the User of the profile, again enabling Replace all child objects. User can login, and you have access to files. – David T Oct 7 '16 at 15:12
  • Hi David, On logging into the administrators account on the laptop today to apply the fix you provided it seems that the permissions have fixed themselves! I was able to access the same user folder (as admin) without any of the above permission prompts and in the security tab the admins account has full permissions. I haven't changed anything since I last tried accessing the folder. Any ideas on what's happened here? – Kol12 Oct 8 '16 at 4:06
  • Major permissions like that won't usually change. Drill thru event viewer, see if something pops up. Win10 updates are basically new installs which could do it. Other than that... – David T Oct 10 '16 at 16:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.