0

Windows Server 2008 R2 with Remote Desktop allowed using less secure option. Firewall is allowing port 3389 through firewall. Group policy is set to Allow for Remote Desktop exceptions. It is also allowing from Remote Terminal Services. CMD netstat shows that 3389 is LISTENING.

When I try to connect to the system from any computer on my network it will not connect and fail to initialize. I can ping the server. I can get to the file shares. I cannot Remote to it. Is there a setting I missed?

  • 1
    internal or external to your network? – Ramhound Oct 6 '16 at 16:09
  • @Ramhound Internal – JukEboX Oct 6 '16 at 16:22
  • If you are connecting to a PC within your network from another PC within you network then why did you forward the port? – Ramhound Oct 6 '16 at 16:26
  • @Ramhound I am allowing the port through the local firewall not the router firewall. – JukEboX Oct 6 '16 at 16:29
1

try adding a user to Remote Desktop Users.

To provide users with remote desktop access, open the Control Panel -> System and Maintenance -> System -> Remote settings and click on the Select Users button to invoke the Remote Desktop Users dialog

  • I am administrator and they are allowed per default. – JukEboX Oct 6 '16 at 16:22
  • @JukEboX You are local administrator? Or in a domain group for server admins, and that group is added to the local administrator's group? You may need your administrator's domain group added to the local remote desktop group. I recognize that the default policy is for administrators to have the right to log on remotely using RDP. But you have other policies in place. Are you positive one of those is not modifying that policy? Also, try connecting with the firewall disabled to confirm that firewall is not blocking. – Xalorous Oct 6 '16 at 18:41
0

Located the answer.

The following policy was set

Computer Configuration > Administrative Templates > Network > Windows Firewall > Domain Policy > Windows Firewall: Allow Remote Desktop exception

Found that it was set to 192.168.0.0/100

Deleted the whole value but still enabled the policy. Reconnected and it now works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.