3

I am using Firefox with the exact same plugins and settings in 3 different machines. Arch Linux, Windows and Ubuntu. In my fresh install of Ubuntu 16.04.1 Firefox won't keep me signed in to Sync no matter how many times I verify my account. Every time I open Firefox it prompts me to verify my account. I do it and less than a minute later I get a yellow exclamation mark that says that I need to verify again.

What could be the cause of this and how can I solve it?

I am using Firefox 49 and my system is up to date.

1
  • Just a curiosity. Is it the Arch Linux machine on with firefox running when you have this problem under Ubuntu. And if firefox on Arch is closed, did it happens nonetheless?
    – Hastur
    Oct 13, 2016 at 9:32

3 Answers 3

1

Bugged me on all my Linux installations for some time but I solved it.

The problem comes from a Firefox extension that seems to be installed on all distribution I have tried, Arch, Ubuntu and Centos; it's the "KDE Wallet password intgration". Disable it and sync will work properly. I have tried setting up KDE Wallet correctly, but sync didn't work even though I was asked for my master password on browser boot.

0

You can try to disconnect from Sync and reconnect

and

possibly delete the signedInUser.json file in the profile folder with Firefox closed.

You can use this button to go to the currently used Firefox profile folder:

Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
[http://kb.mozillazine.org/Profile_folder_-_Firefox][1] 
-1

I don't know if it's going to help, but I think the problem there is that firefox has difficulties with ubuntu. I think it's possible to fix this though, try to check this topic about firefox syncing problems : https://support.mozilla.org/en-US/questions/1075451 If your problem has nothing to do about reading the sync log maybe the topic above might not be useful. Also check this other topic, it might help : https://support.mozilla.org/en-US/questions/1047148 Also on another topic about ubuntu syncing problems, someone said it might be related to the json files, ubuntu has apparently some problems reading json files (a friend plays minecraft on ubuntu and it runs at 20 fps, minecraft uses java and json files) I'm not a professionnal, so I might be wrong as well. Hope it helped anyways.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.