5

It's not wise to store the recovery key on flash drive, for example. That means anyone that steal my computer and my flash drive can easily decrypt my recovery key. That defeats the purpose of encrypting it in the first place.

So I tried to save my Bitlocker recovery key somewhere, and a nice place to put it is of course my Microsoft account.

Yet, when I try I get a message "Can't save to your Microsoft account":

enter image description here

How can I successfully save my Bitlocker key to my Microsoft account?

My problem is similar to what's discussed here at answer.microsoft.com.

2
  • When you link a Microsoft Account to a local machine on a Windows 8 and Windows 10 machine, the authorized user of the MS account has to verify the machine should be added, until you do that it does not have full access to the account. This has been the case since the release of Windows 8.
    – Ramhound
    Oct 7, 2016 at 14:05
  • FYI: I had to temporarily make my Microsoft account an "Administrator" since trying to backup the recovery key requires administrator access. After typing in my admin account credentials, I assume it was attempting to use that account to connect. Since that one is just a local Admin, not a Microsoft account, I think that was my problem.
    – Boyd P
    Nov 29, 2017 at 23:54

5 Answers 5

6

Go to settings (in Windows 10 it's in lower right corner), and select Account.

So settings -> all settings -> accounts.

Turns out there is a text saying that they need to verify my identity.

I click on that and put my pin.

I can now save my Bitlocker key to my Microsoft account.

It's kind of strange though. I always use my pin when I am logging in. So go figure.

3
  • 1
    When you log in, MS live.com (or whatever they call it now) verifies your login credentials and authenticates you to your computer. Note how I did not say that it authenticates you to your MS account. That is separate. That is a good thing.
    – Jeter-work
    Oct 7, 2016 at 13:49
  • After some bios / TPM updates I cleared the TPM and needed to verify the account. This fixed my issue.
    – PeterI
    May 30, 2019 at 21:58
  • On my build of Windows 10 you can find this by going to "Settings", "Accounts" and then under "Sync your settings" the "Passwords" option had the message about needing to verify the account. Jan 20, 2020 at 10:22
1

Just posting on this thread after having the same problem and not being able to solve it for the life of me using all the methods I had seen, but then worked it out.

Check if you have any firewall or DNS blocking anywhere on your network. I am running a pi-hole local DNS server to block advertising/tracking and turns out the server used by bitlocker to store the key was being blocked, so none of the local settings made any difference. I turned filtering off for a few minutes and it worked straight away.

Hope that is useful for anyone else stuck on this!

1
  • My hero; DNS blocking got me too
    – Chris
    Jan 24 at 23:59
0

I ended up changing my account to a local account, logging in and changing it back to a Microsoft account. Logged back in an I was then able to back up all my Bitlocker keys to my MS account.

0

I researched several sites and possible solutions for this issue. But after trying them all to no success, I backed up my files on my PC and did a complete systems reset. After the reset I was able to back up my Recovery to Azure AD and enable Bitlocker comfortably.

0

I had a very similar problem when setting up bitlocker on my work machine.

For compliance reasons our main user login is a "Standard" user and we have a password protected "Administrator" user for doing anything that requires elevated privledges.

The standard user is associated with a MS account, and the admin user is a local account.

If you try to backup from the standard user, it requires elevated privledges, so will require the admin user's password. This then fails to backup as it's (presumably) trying to use the MS account for the local admin user.

The only way I could get round this was setting the standard user account type to Administrator. Then the backup to MS account works fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .