On Leopard, I use Mail.app. I have filters set up. They work. Except for this new one I made. It works when I choose Apply Filters manually. But does not seem to filter incoming messages.

It is my only filter that operates on something in the IMAP Gmail Spam folder. I think that mail just sees this as any other IMAP folder, so I don't know why it won't work. But do you think that Mail.App does realize that this IMAP/spam folder is actually a spam/junk folder and for some reason because of this it prevents my filter from being run?

As I said all my other filters work fine.


I think the spam detection of gmail is a filter applied before others...

How to deal with it:

  • To filter mails flagged as spam: add label:spam in the "Has the words" input box.
  • To avoid the spam flagging, create a filter that describes the cases when Gmail should not flag the incoming messages as spam and then check "Never send it to spam".

source: googlesystem.blogspot.com

alt text

  • thanks, I have multiple gmail account so would prefer to filter once they are in mail.app. But if that is not possible I will do it your way and the same filters to all my gmail accounts. Basically I like to check my spam folder before deleting messages, but right now i am getting so many "ED Meds" and "ED Pills" messsages that they even flood my spam folder... so I wanted to make filters to clear those out... and leave the rest of my spam for manual checking before deleting – Mikey Feb 25 '10 at 10:46
  • you could export/import your filters in the gmail webapp... – fluxtendu Feb 25 '10 at 11:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.