2

I got into a hotel that has two wifi options: standard and premium. the first time i connected to the hotel wifi (on mac) it showed me the default captive page. I went with the free one.

However I later on purchased the premium card.. but now I have no idea how to make that captive page show up again since it simply re-logs using the free account. Any idea how I can force it to show the captive page again? I already erased cache etc of chrome/safari.. no luck

update

so the network is called citymax.. i found this in

/Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist 

    <key>wifi.ssid.&lt;43495459 4d4158&gt;</key>
    <dict>
        <key>AutoLogin</key>
        <true/>
        <key>Captive</key>
        <true/>
        <key>ChannelHistory</key>
        <array>
            <dict>
                <key>Channel</key>
                <integer>161</integer>
                <key>Timestamp</key>
                <date>2016-10-07T20:46:51Z</date>
            </dict>
            <dict>
                <key>Channel</key>
                <integer>149</integer>
                <key>Timestamp</key>
                <date>2016-10-07T20:45:52Z</date>
            </dict>
        </array>
        <key>Closed</key>
        <false/>
        <key>CollocatedGroup</key>
        <array>
            <string>wifi.ssid.&lt;42554646 414c4f2d 43313143 3134&gt;</string>
        </array>
        <key>Disabled</key>
        <false/>
        <key>LastConnected</key>
        <date>2016-10-07T20:46:51Z</date>
        <key>Passpoint</key>
        <false/>
        <key>PersonalHotspot</key>
        <false/>
        <key>PossiblyHiddenNetwork</key>
        <false/>
        <key>RoamingProfileType</key>
        <string>Multi</string>
        <key>SPRoaming</key>
        <false/>
        <key>SSID</key>
        <data>
        Q0lUWU1BWA==
        </data>
        <key>SSIDString</key>
        <string>CITYMAX</string>
        <key>SecurityType</key>
        <string>Open</string>
        <key>SystemMode</key>
        <true/>
        <key>TemporarilyDisabled</key>
        <false/>
    </dict>

i tried playing around with those values (even deleting the entire key) but no luck.. any ideas?

2

First thing I would attempt would be to try going to the url of the default gateway.

If that does not work you will probably have to change your mac address. Most systems go off the network adapter's mac address.

| improve this answer | |
  • Sadly I am not familiar with Apple. – birdman3131 Oct 7 '16 at 21:06
0

In the settings section of your mac, select Airport/WI-FI, you should see an ADVANCED button, click on it, then in the airport tab, select the citymax network click on “-” (minus sign) . This should remove the network and ask you again for proper configuration.

| improve this answer | |
  • Tried it didn't work – abbood Oct 8 '16 at 4:18
0

Partial answer: Some Captive Portal solutions set some cookies on the browser for session persistence. Try browsing on private mode to see if it works.

| improve this answer | |
  • Already tried didn't work – abbood Oct 8 '16 at 4:25
-3

I discovered a way to force captive portal WiFi login page to load... opening the browser and typing in the address bar the URL bing.com

Not google and no other way but with bing.com and every time I have a hanging WiFi connection issue with captive portal login page not coming up or loading when I use bing.com I am met with a forced to login pop up or webpage load access.

| improve this answer | |
  • Shameless plug for a bad search engine? – Danny A Dec 27 '19 at 15:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.