6

I've been trying to google a solution for while now to no avail.

I am using multiple keyboard layouts for multiple languages. I have set up shortcuts (Alt + Shift + #) for 8 such layouts. However, just like in Windows 7, they sometimes get reset upon system startup or waking from hibernate.

Previous resets were linked to a big system update and change in keyboard layouts (interestingly, Windows 10 synchronizes them between computers of the same user), but now it's just random. I keep setting them up, but they keep getting reset every now and then on both of my computers.

Does anybody know how to avoid that, or at least how to speed up re-inputting the shortcuts? Maybe a registry file that would fix it with one click?

Most of the keyboard layouts are custom-made by me, one is a downloaded one, and the rest are original MS layouts.

4

It seems that I have been able to resolve this problem—and since nobody addressed this specific issue, let me tell you how I did it.

It turns out that Windows 10 (and some previous versions as well) has separate language settings for the lock screen. When you install your own custom layouts, Windows sets up its own counterpart for the lock screen—probably to avoid problems with non-standard input.

So whenever you bring a computer from sleep, hibernation, screensaver or the lock screen, it switches between those two sets of layouts: your custom ones and it's default counterparts. But if they don't match—i.e. you have your own French keyboard layout, and the lock screen has the MS French keyboard layout—Windows simply resets the layout shortcuts until restarted.

The solution, hence, is to copy your custom keyboard layout settings to the lock screen. You can do this in the Control Panel: Control Panel → Time and Regional Settings → Language → Advanced Settings → Apply language settings to lock screen…. Be sure to select both options in the prompt window that follows!

This has worked on all of my Windows 10 computers.

1

On Win 10 LSTC it lies in: Control Panel -> Clock and Region -> Region (Change date, time or number formats) -> Administrative Tab -> Copy settings -> set both check-boxes

check-boxes screenshot

  • 2
    Welcome to Super User. Consider adding a screen shot or including the name of the two check boxes in case another option be added in the future, making your answer ambiguous. – Twisty Impersonator Aug 7 at 21:29
1

This has been a recurring problem for me as well. Recently the program Keyman has been released as free software, and it enables you to create keyboard shortcuts for keyboards just like Windows does. (You can create shortcuts either for Keyman keyboards, or for the Windows keyboards you already have installed.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.