0

This question already has an answer here:

I have SanDisk Cruzer 16GB Pen drive. Certainly, I am unable to copy any data into it (You feel that this question is duplicate. but, my situation is different.). It throws an error message as

This device is write protected.

I have googled and found two possible solutions such as,

  1. Use DISKPART to remove this error.
  2. Add attribute in RegEdit...

In my case, both of the solution doesn't help me. And also, I have noticed when I ran DISKPART as: my pen drive is in Current Read-only state: yes not Read-Only: yes.

Could any one please help me to resolve this?

marked as duplicate by DavidPostill, fixer1234, techraf, 3498DB, mdpc Oct 28 '16 at 22:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Test it on multiple computers (just to be sure and mentioned in the duplicate of link, try different OSes too). I had a few of those and some I was able to fix with different format utilities (I was able to recover a 16GB Toshiba which went into read-only). I can't tell you what utility it was because this is dependent of the chipset used in the pen drive. Check the device ID and search on the Internet (not necessarily a SanDisk utility). – Zina Oct 8 '16 at 10:13
  • "The solution doesn't help me" isn't clear. The dupe describes the few cases where you might be able to fix it. Otherwise, it's trash. That's all the help there is. – fixer1234 Oct 9 '16 at 2:36
0

Did you already check this -> Sandisk USB drive is read only ?

Checked several USB-sticks incl. SanDisk, and found that DISKPART SET READONLY and CLEAR READONLY changed undoubtely the both definitions from -> no into -> yes, and back into -> no .

If not yet tried, and you would like do it after taking a backup of the data, what would the statuses be/become if first applying SET READONLY, and then back with CLEAR READONLY ...

Not the answer you're looking for? Browse other questions tagged or ask your own question.