2

My MacBookPro running macOS Sierra has been recently continuously receiving bluetooth pairing requests from an unknown HTC device. The first couple of times I kept on clicking the ignore button, and then I realized there is a checkbox at the bottom of the pair request window that remembers the action for the device and so I clicked it thinking that it will block the device from pairing from here on. Unfortunately, all this did is make the pairing request window pop up momentarily and instantaneously disappear every now and then; which is annoying because the scope of my keyboard keeps switching every time this happens. One thing that surprises me is that even with the bluetooth settings window closed, and therefore the mac being undiscoverable, I am still getting the pairing requests. I looked extensively trying to find a solution but all the solutions seem to only work if the device is already paired or if you know the mac address of the device. Does anyone have any idea how I can permanently block the device, or at least find it's mac address and add it to the list of blocked devices in the com.apple.Bluettoth.plist?

6
  • Did you see this question? superuser.com/questions/916038/… Would be interesting to see if it is the same problem.
    – Tonny
    Oct 8, 2016 at 15:44
  • @Tonny Yes I did but he is able to use xcode tools that you can only have access to if you are a registered apple developer which I am not. Are you aware of any such tools that can be downloaded freely? I'm sure that if I get my hand on the mac address of the offending device I would be able to block it somehow.
    – adelejjeh
    Oct 8, 2016 at 15:47
  • The accepted answer on that question mentions to disable the Handoff feature. This is unrelated to XCode. He just used the XCode tools to investigate. Handoff feature can be switched on/off in System Preferences. It is had the bottom of the General section. Woudl be interresting to see if that fixes the issue in your case too.
    – Tonny
    Oct 8, 2016 at 15:52
  • I'll try that, but Handoff is usually between apple devices. The device in question in my case is an HTC.
    – adelejjeh
    Oct 8, 2016 at 18:08
  • I turned off handoff but I'm still getting the pairing request. I don't think this helped.
    – adelejjeh
    Oct 8, 2016 at 18:25

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.