98

I try to switch a window from my second monitor to the first, because my OS always opens some windows where they were last closed. E.g. if I open up VLC Player to watch a video and then move the window to monitor B, close it and reopen it, then it is opened on monitor B the next time.

This is obviously very annoying, especially if monitor B is not on.

Is there a shortcut so I can move the windows easily to monitor A again if it has focus?


I tried to give the window focus and press

Windows+SHIFT+ or: Windows+SHIFT+

But nothing happens.

  • 69
    Windows+SHIFT+→ works for me on four monitors. – Peter Hahndorf Oct 9 '16 at 16:42
  • Thanks for your Feedback! Thats weird, shouldn't it work for me aswell then? – Black Oct 10 '16 at 6:10
  • 1
    I would think so, if it doesn't, there may be third party tools intercepting keyboard calls. Not sure. – Peter Hahndorf Oct 10 '16 at 6:14
  • I will check for any external software. It didn't worked before i upgraded from windows 7 to windows 10 either. – Black Oct 10 '16 at 6:35
  • 2
    For me it's just Windows+Cursor Keys to move windows across desktops by switching them through various sizes. – Seth Oct 10 '16 at 7:31
29

I solved it by unchecking the box which you can see in the following screenshot. Ease of access English version

Go to Control Panel > Ease of Access Center > Make the Keyboard Easier to Use

Then search for the setting "Make it easier to manage windows" and un-check "Prevent windows from being automatically arranged when moved to the edge of the screen"

After unchecking this option, it works again.

| improve this answer | |
  • 4
    English screenshot. However this also disables snapping (dragging windows to edges or Windows+left/right) – phuclv Oct 20 '17 at 9:54
21

Go to Settings -> System -> Multitasking

The first section in the Multitasking settings is called Snap.  I had the first four items in the list set to Off.  When I changed them to On, it (moving windows with Windows+Shift+ / (Right / Left arrow key) started working again.

IMG:
(Click image to enlarge)

| improve this answer | |
11

An alternative method of moving desktop applications using the keyboard, is to open the application system menu by pressing ALT + Space and then press m to select move. Then you can use the arrow keys to move the application window. I regularly use this to move applications that are placed outside my desktop.

Note that this will not work if "move" is disabled in the application. Which will be the case if the application is maximized.

This method also works when "Prevent windows from being automatically arranged when moved to the edge of the screen" is checked in the control panel.

| improve this answer | |
  • "Note that this will not work if "move" is disabled in the application. Which will be the case if the application is maximized." In that case, Windows will boing at you to let you know it's not working; then Alt+ Space then R will restore the window to non-full screen and THEN you can ALT + Space, M arrowkey to move it. – Steve Rindsberg Nov 6 '18 at 15:44
  • You save my life! It is midnight now and I have to do some urgent work on remote PC. Since I have 2 monitor and Google remote desktop only support single screen. Visual Studio is opened and unsave work on 2nd monitor, so I have to move to primary screen. The ALT+SPACE is works, and classical method always work! – Cheung Jan 19 '19 at 17:56
  • Alt+space does nothing in my Win 10. Why? – Pedro77 Dec 25 '19 at 19:22
  • 1
    @Pedro77 Alt+space opens the window menu of the active application. The application has to be made active first. Applications can disable this behaviour. – staaleh Dec 27 '19 at 11:26
7

A couple things that can prevent this key combo from working are:

  1. Filter Keys is turned on.

    Open the "Ease of Access Keyboard Settings" page and disable this feature.

    Filter Keys Off

  2. GPO: "Turn off Windows+X hotkeys" is enabled.

    Do the reverse of what this article details. This is less likely to cause the issue, as having this enabled did not prevent the hotkey from working in my tests, but I suppose it's theoretically possible.

I may add additional causes if I discover any, but I hope this helps resolve your current issue. :)

| improve this answer | |
  • Thank you, I am currently not at home and can't try it, but i will do and report back :). I already solved it though it was indeed a windows setting. I will report asap how I solved it. – Black Mar 10 '17 at 10:03
  • 1
    This totally worked for me, but I had "Filter Keys" already turned "off" but I also had to disable "Allow the shortcut key to start filter keys" since it was blocking the <shift> key from working. – DH4 Sep 30 '19 at 2:16
  • Up votes are always appreciated mate. Cheers. – Chiramisu Sep 30 '19 at 3:23
2

In the newer Versions of Windows (1903) the Snap Dialog has changed.

It is necessary to have Snap on to use Alt-Shift-Arrow. The checkboxes below do not have an impact.

enter image description here

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.