0

Anyone else experiencing this problem after upgrading to MacOS Sierra and using Xampp 5.6.X?

Have been using Xampp to test WordPress for years now, never had an issue, however now it seems that external calls to WordPress are now being blocked.

I am assuming this is a security “feature” that MacOS introduces, but I cannot seem to put my finger on how to change it.

The symptoms:

  • When I load the front end of the WP website, the site loads instantly.
  • Loading a local site that does not use Wordpress is also instant
  • Once I log into the WordPress Admin panel (Dashboard), it takes between 10-20 seconds to load, with some instances of timing out with “Your connection has been reset” (on Firefox)

  • When DEBUG is on, I can see this on the Plugin Page:

Error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in /Applications/XAMPP/xamppfiles/htdocs/site/wp-admin/includes/plugin-install.php on line 158

  • If I add: define('WP_HTTP_BLOCK_EXTERNAL', true); To my wp-config.php, the backend loads instantly, however Adding Plugins and the dashboard news no longer works.

I’ve tried to update my .CA bundle from the official Curl site and insured that it’s pointing correctly in my php.ini but it hasn’t worked.

Anyone else experience this? It seems the error is related to outbound connections through PHP... where should I be looking? Thanks!

2

After doing some more testing, I made this script:

include('wp-config.php');

$url = "http://api.wordpress.org/plugins/info/1.0/";

$http_args = array(
            'timeout' => 15,
            'body' => array(
                'action' => $action,
                'request' => serialize( $args )
            )
        );


print_r($request = wp_remote_post( $url, $http_args ));

And sure enough I found this error:

cURL error 6: name lookup timed out

Turned out to be a DNS problem, so I went to:

System Preferences > Network > Advanced > DNS and changed the default DNS to 8.8.8.8 and 8.8.4.4 (Google's Public DNS) and behold, it worked. I Hope this helps someone else out.

0

This isn't technically a solution, but after experiencing this problem I started using OSXs built-in Apache, downloaded an SQL Server etc.. It took a while to get my head around it but it sorted the issue.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.