3

enter image description here

I get the following error from VMware Player. A solution would be to run the commands mentioned in the thread below. Is there some other way to do this however? I do not wan't to mess around to much since I wan't to be able to restore all settings to their previous values later.

What are these VMWare instructions actually doing? (Disabling device guard and removing EFI variables)

  • If there were a better known workaround, then VMware probably would suggest using that instead. Since VMware doesn't, there probably isn't. – jamesdlin Oct 24 '16 at 21:35
6

This worked for me:
1) Disable Hyper-V in the host with this command in the cmd (as admin): bcdedit /set hypervisorlaunchtype off
2) Restart host

  • Well, this fixed the problem for VMWare, but now Docker is broke on the host machine. – senfo May 15 at 22:37
2

I had to do an extra step to make it go away:

Settings > Update and security > Windows security > virus and thread protection > Device security > Core isolation > core isolation details > (Turn off memory integrity)

Info:

Windows 10 1803 build 17134.137
i7 7700
VMware workstation pro 14.0.0 build-6661328

1

Though this is a workaround, an answer to this question is posted in a VMWare article, which solved the problem for me:

Powering on a vm in VMware Workstation on Windows 10 host where Credential Guard/Device Guard is enabled fails with BSOD

According to the article, the cause of the problem is incompatibility between the Windows Device Guard and Credential Guard with VMWare workstation. In brief, this mechanism exists on Windows to prevent the execution of malicious code. You can find more details about it here:

Windows Device Guard and Credential Guard Demystified

The workaround involves disabling this mechanism (in effect solving the problem), however do so with caution, as this may entail a potential security risk while executing future code.

1

There is a https://github.com/ygoe/HyperVSwitch GUI tool to temporarily disable Hyper-V without uninstalling. This requires system reboot, unfortunately.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.