2

I'm trying to use Linphone on a Windows 7 machine that is connected to multiple networks (via 2 different NICs). It works fine with a single one connected, but when both are connected I only get one way audio (from the multi-network computer to the other device) and the connection closes after ~30 seconds with a connection lost message.

The issue appears to be that Linphone is somehow automatically selecting an IP address to put in the SIP INVITE connection address field and the address it chooses is not associated with the NIC that it used to send the INVITE (so the other side of the call tries to respond on a different network). I tried adjusting the priority of the network interfaces in Windows, but that had no effect.

In the example in the screenshot below, the INVITE is sent from 192.168.0.41 to 192.168.0.241, but the SIP Connection Address is set to 10.0.0.250 (the second NIC) instead of 192.168.0.41.

SIP INVITE containing wrong IP in Connection Information

Just wondering if there is a way to resolve this throught either Linphone settings or adjusting network settings in Windows?

1

One solution is to use the Network Settings -> NAT and Firewall: Behind NAT / Firewall option. Enabling this option and setting the Public IP address to the address of the NIC that should be used will result in the SIP INVITE being sent with the correction connection address. Note that this works in a small network that isn't being routed externally.

Linphone Network Settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.