0

I've successfully added 2FA with Google Authenticator package on openSUSE Leap 42.1 for Display Manager, login, sudo and su. I have to enter a verification code from Android app every time I use these tools (both for my main user and root).

However, when I e.g. try to install software via GUI with Yast2 there's no field to enter the code. I enter my root password and Yast's window freezes (probably waiting for the code). The reason is that Yast2 uses su. So when I comment out the line with Google Authenticator in /etc/pam.d/su I can open Yast and install software, change system settings, etc.

How can I make Yast2 ask me for verification codes?

0

It sounds like you are having a similar problem to one I have encountered with AppleID accounts with Two-Factor enabled running on legacy OSX versions. Try appending the code to the end of your password string with no spaces.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.