27

I have a problem with my keyboard layout. When I bought my new keyboard, I set the Windows layout to US International cause it has US layout but I still need to type international characters.

Everything worked just fine as I wanted it to, that is. For example, I had to press AltGr+E to type é and pressing '+E resulted in 'e and not é.

The problem is, I don't know how but this just changed 10 minutes ago, and now if I press '+E, it types é and not 'e, as I want. I did some research and found out this is what "dead keys" do, and unfortunately it is not how I want my keyboard to work.

I read a lot of people suggesting to use the Microsoft keyboard layout creator or just switching to the US layout to disable the dead keys, but, unless I just got crazy, I can assure you all I was using the international layout WITHOUT dead keys just till 10 minutes ago.  I am not confusing ' Apostrophe and ` Grave Accent (backtick).  I am 100% sure, because my language has a lot of apostrophes followed by vowels, so if this was happening before I would have recognized – typing, for example, límbuto instead of l'imbuto. It is annoying.

Please, does someone know if there is some way to disable this dead keys feature in the US International layout?

4
  • 1
    Probably you are confusing ' Apostrophe and ``` Grave Accent (backtick). Both work as a dead key for US-International keyboard layout but for different letter+accent combinations.
    – JosefZ
    Oct 10 '16 at 22:37
  • 1
    No i am not. I used to press apostrophe(the key near the right shift)+vocal to get apostrophevocal, but i don't know how this turned to accentedvocal by itself. As i said, i was not using US standard layout before as i was able to type accentedvocal by pressing altgr+vocal. I hope i explained myself.
    – Drakem
    Oct 10 '16 at 22:41
  • 1
    Maybe that you have both US standard and US-international layouts installed and you are switching them accidentally by mistake? For instance, I fall out such mistakes every now and then (having more languages + kbd layouts installed). Try WinKey+Space.
    – JosefZ
    Oct 10 '16 at 22:57
  • 1
    I only have 2 layouts active, US Int and Italian. If i was switching by mistake to US standard (that is not in my layouts anyway) i would not have accented vocals by typing altgr+vocal, this can't be it.
    – Drakem
    Oct 10 '16 at 23:12
23

I ran into a somewhat similar problem with the US-International layout. I am using it to type some non-ASCII characters that are available through AltGr combinations (such as ö and ä) but want to keep the default behaviour of other keys, in particular the ' and " keys.

I made a GitHub repository holding a layout that does that. The layout file (direct link) can be opened in Microsoft's Keyboard Layout Creator tool (free as in beer), and built with it. Running the resulting installer adds the new layout to Windows where it can be used exactly like the builtin layouts.

0
4

This is a misunderstanding of Input Language and Keyboard Layout. I often find people despaired because they are not able to type accents. This happens because people usually match Input Language and Keyboard Layout, and this is incorrect (except if you want to input the same language as the keyboard was designed to).

The first thing you should do is to set YOUR input language. This has NOTHING to do with your keyboard layout, this is a personal setting. If your language is set to English, there will be no good support to type characters like á or ç, because they don't exist in english. Simple as it is.

So if your language is Italy's Italian, you should select "Italian (Italy)" as input language, and no other one should exist in the list (except if you want to be able to type in several incompatible languages, which rarely is the case).

After you set your language input, you will select your keyboard layout. This is a different thing, because it depends on the keyboard you are using. If your keyboard is US-International, just set it. But always assure the Input Language is the language you really want to use, not your keyboard's country of origin.

For example, I am brazilian. I want to input text in brazilian portuguese, but my keyboard is US-International like yours. What is the correct setting for me?

  • Input Language: Portuguese (Brazil)
  • Keyboard layout: United States-International

Example of correct language settings on Windows 10

This can be vary for each person. I can, for example, use Portuguese as my input language, but with a Japanese Keyboard. This may sounds odd, but it is possible.

Lastly, note that Windows does NOT set this configuration for you by default. By default, it always guess that your language input matches your keyboard layout (during Windows first launch, they ask what's your keyboard layout and set your input language to the same). Worst than that, you are not able to remove the input language originally set if there is only one input language (so a lot of people think it is not possible to change the input language).

So, to properly set your system, you should:

  1. Add a new language input (ex. Portuguese (Brazil))
  2. Set the keyboard layout for the input language your just add (ex. United States-International)
  3. Move it up to the top of the list (to make it the main language)
  4. Remove the other languages (so your system won't use the other languages by accident)
13
  • Having multiple keyboards is an advantage. The OP problem was that it only had one keyboard layout under one language and the tray button was therefore hidden. What the OP asks is impossible: there is no International US without dead keys. To avoid dead keys one should get other keyboard layout.
    – user162573
    Jun 21 '18 at 11:35
  • On Windows, the "with dead keys" and "without dead keys" setting is not related with keyboard layout. If you set your input language as "Italian (Italy)" the US keyboard will present dead key behavior because they are needed to type in that language. On the other hand, if you select "English (United States)" as input language, the keyboard will not present dead key behavior, because they are not used in english. Thus, opposing to what you said, there is an International US without dead keys, not with this name, and you don't set this as a keyboard layout (as you usually do in Linux systems). Jun 21 '18 at 11:52
  • and where is that US international without the dead keys? I only see US English keyboard (added by default when English is the only language) and US International (which includes the dead keys). Have I missed it? - Do you know that the OP was not using US English as the main language? Was he using Italian? What he says is that he used to have English without dead keys and by some change he got English with dead keys. That keyboard could be under many different main "language".
    – user162573
    Jun 22 '18 at 7:44
  • 2
    Ok, forget anything I've said, you are correct... Apparently there is a difference between "US" keyboard layout and "US International" keyboard layout that I didn't notice. I just tested and US International layout present dead key behavior and it doesn't matter what input language I select. This means the setting I was sure for years was incorrect. Sadly, the US layout doesn't have the AltGr key, so I don't know how to enable all functionality of US International, disabling only the dead keys, without making a new keyboard layout. I'll edit the answer to reflect these new findings... Jun 22 '18 at 11:43
  • 1
    In the beginning I also thought it was due to some recent Windows update, but I just tested some old systems (Windows 7, Windows 2008, etc) and all present the same behavior. I probably made a confusion with "US" and "US International" keyboard layouts. Jun 22 '18 at 11:46
3

The post is old now and must have been fixed long ago.

But the answers are not that clear, especially the most upvoted here. (Why should the OP add United States International (and for Brazil Portuguese for that matter) when that keyboard is in fact including dead keys, which the OP already has but wants to go without?)

What the OP asks is impossible (English US International without dead keys).

...Unless a new keyboard layout is created by a third party - as suggested in this answer.


On the difference between "language"and "keyboard":

  • When you install Windows (or customize it initially) a system language is selected that cannot be removed even after a second one was installed/added under Settings/Time&Language/Region&language.

  • Every "Language" under those settings comes with a keyboard by default and not much more (and thus it doesn't mean more then a collection of keyboards - unlike what the other answer says); but under its options you can also add, if you chose to download them, a language pack, a handwriting package, and a speech package.

enter image description here

  • No matter that, whether you add many languages (each with at least one keyboard; the last of which cannot be remove without removing the language) or just one language (with one or more keyboards) what you see and can switch in the tray button/list is always keyboards.

While you cannot add a keyboard without adding a language (and you can add multiple keyboards under one language), adding (having) a "language" always means adding at least one keyboard. What is in fact "added" are always keyboards. Different keyboards are added under each language's "Options", then the keyboards are displayed in the list accessed by clicking the specific tray button.

enter image description here


Considering English US International

That is not the default keyboard under any language as far as I can tell. Also, it seems that under all languages that I have tested English US International keyboard has dead keys.


For the OP not to be able to see that list and switch to the normal default English US, and be stuck to English US International (which has dead keys), that latter layout must have been the only one keyboard added.

When only one language with only one keyboard is added (and this is the default case: except normally that is the simple US not the US Intl), the tray button for keyboards is missing.

What in Linux is called English US International with Dead Keys is simply called English US International in Windows 10. Somehow that has become the only keyboard layout.

To have access to US English without dead keys the simple US keyboard needs to be added.

enter image description here

enter image description here

But that doesn't do what the OP asks, an English keyboard without dead keys but with the ability of doing é with AltGR+e. The OP should have asked a new more specific question.

With the available keyboard layouts, for accented characters I would suggest keeping also the English US International (and keeping the dead keys for accented characters) and switching easily between keyboards with Super-Space. If one refuses dead keys by all means, one should find a new keyboard that includes accents without dead keys. (For example, for French, one could add French language: that is, language AND keyboard.)

enter image description here

1
  • 1
    it's not impossible. there are layouts that add diacritics without dead keys
    – mendota
    Apr 22 '19 at 17:35
0

Not a direct answer to your question, but a solution that eliminates the need for the international layout in the first place.

I use AutoHotkey for typing non-English characters with a modifier key, it's very easy to set up. Just install it, create a text file with .ahk extension that will have the keys to remap and run the file. An icon will appear in the tray that allows you to control the running script.

For example, the following two lines will bind Alt+E to é and Alt+Shift+E to É:

!e::Send é
!+e::Send É

Add all the letters that you want and you're all set.

Make sure to save the file as Unicode or UTF-8 with BOM.

In case you want to bind only the right Alt, not both, you can do it this way:

>!e::Send é
>!+e::Send É

For more details, see the manual here.

0

Best working solution to me. But not 100% what the OP wanted as it doesn't eliminate dead key.

Simply pressing SPACE after any of the dead keys puts only the wanted symbol; no extra space. 'SPACEE puts the wanted 'e in contrary to 'E putting é.

There's no need to fiddle around with configuring anything extra or always having to switch your input with WIN+SPACE. It also should work for any other language's keyboard. Once I got used to this I didn't feel like I needed another solution for that.

0

I also argue that I have made an implementation using an AHK script (MSKLC implementation also available).

I have designed UltimateKEYS and its corresponding GitHub repository.

This is a project which I have developed (partially based on EurKEY) and which aims to harmonize languages with Latin-based alphabets on US QWERTY, having the dead key combinations, etc. on AltGr and AltGr+Shift.

This is the UltimateKEYS Keyboard Layout:

UltimateKEYS Keyboard Layout

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.