0

At first this may seem like a duplicate question, however; I can assure you it is not, and I have searched extensively for the answer to no avail.

I was working away in PowerPoint, when suddenly the keyboard layout spontaneously decided to become French. This was quite puzzling, since I did not have the French keyboard layout installed at any point, so it cannot be the common, "Oops, I accidentally hit Alt + Left-Shit, again." issue.

WHAT I'VE TRIED

  1. I've looked into the keyboard settings in the Region and Language Settings, and verified that US is the only keyboard layout installed.
  2. I checked to make sure the word French appears no where in the locale, regional or language settings.
  3. I installed the French keyboard, switched to it and back - FAIL
  4. I uninstalled French and installed Canadian Multi-language, switched to it and back - FAIL
  5. I installed a Cyrillic keyboard and switched to that. When I start typing, lo and behold, FRENCH!

I am at my wit's end with this problem.

--EDIT--

Point of Clarification

By stuck in French, I mean that, while I only have a single keyboard layout installed (US), the actual typing method is French, as in the forward slash produces é, and the open square bracket produces an accent on whichever character follows ê. Having only one keyboard layout installed, I do not have an EN for English, an FR for French, or even an SB for Serbian, because there is no need for a language bar when a single input language is installed. For whatever reason, irregardless of which single keyboard layout I install, the only output on screen is that from using a French keyboard layout. Even in my troubleshooting steps, when I did have multiple languages installed and the EN showed up, when I type, it it as though I am using the French layout. When I switched to Serbian Cyrillic, the SB showed up, but still the behavior of using a French layout remained. It matters not which layout I actually have installed or activated, French input prevails. Hence, "Stuck on French".

5
  • You are not clear about what "stuck on French" means. Does it mean that FR (or whatever French would display as) is displayed in the language bar? You should add a screenshot of the language bar with options displayed, along with one of the keyboard dialog from the control panel. Also do you have a US English, Canadian or other localized OS version?
    – user3169
    Oct 11, 2016 at 5:44
  • @user3169 I am running the signature edition of Win7 Ultimate, from the product launch, so not a localized version, to my knowledge. That said, my locale was set to Canada, but I have changed it to US. Not a speck of difference in the world. Oct 14, 2016 at 20:44
  • OS was downloaded/purchased from the US? And was US English version? Don't know for sure, but if another version it should be indicated in the System control panel. Is the OS updated to current (SP1, updates, etc.)? And are you sure the keyboard is standard English version? Beyond other issues it seems like a hardware issue somehow.
    – user3169
    Oct 14, 2016 at 21:13
  • You don't really say, but I presume this happens in all apps, not just Office, right?
    – user3169
    Oct 14, 2016 at 21:17
  • @user3169 You are correct in your assumption that it is Windows wide, and not just Office. I did manage to solve the problem, and shall post an answer shortly. Oct 24, 2016 at 18:14

2 Answers 2

0

Short Answer

Resource conflict/corruption with TeamViewer.

Long Answer

There had been a recent TeamViewer connection to my PC, and the issue manifested during that connection. However, since the problem persisted following the cessation of the connection, and since restarts did not solve the issue, TeamViewer was too quickly ruled out as the suspect.

TeamViewer has options to translate keystrokes over the connection. Normally I would think this is handled at the remote side, and not the host side, meaning that the TeamViewer remote transmits the translated character, so the host only sees the translated character and not the original typed character. Given that information, you can see how it was natural to rule out TeamViewer as the cause.

Be that as it may, I uninstalled TeamViewer on the Host Machine (the one stuck on French), and my proper keyboard layout was restored! When I re-installed TeamViewer, the problem did not return.

My best guess as to the actual cause would be a corrupt TeamViewer resource that was translating the local input and bouncing it back to the local machine instead of a connected host. Almost like TeamViewer was looped into itself, behaving like both remote and host simultaneously.

-1

I'm not sure if my problem is exactly the same. Your answer helped me solve my problem so just want to mention what I experienced and how I solved it.

I have Danish keyboard layout on both server and client TeamViewer PC. If I go the physical server PC (the one that I will later connect to using TeamViewer) the keyboard layout is Danish and works. At my client PC the keyboard is Danish and it works. If I connect to the server from the client through TeamViewer the keyboard becomes US layout and that was my problem.

Solution: I had the US keyboard layout installed on the client machine though I didn't use it (and it was not the default one). Removing this installed US keyboard layout from the client PC immediately solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.