3

I have Windows 10 Home, normally have many things in progress, and rarely reboot. When Windows does an update and wants to restart, the notification is a very subtle "1" added to the action center icon (which I don't usually notice), and then the next morning it has shut down everything and rebooted. I know that I can't completely control the updates like I could in Windows 7, but I would at least like a clearer announcement, like a popup that stays visible until I close it. I prefer to close my programs myself and reboot on my own terms, rather than Windows doing it to me when I least expect. The question "How to stop Windows 10 from automatic restarts" shows a screenshot of a setting called "Notify to schedule restart", but I can't find such a thing on mine - my Advanced page looks like this: Update & security -> Update settings -> Advanced options

Thoughts?

NOTE: My question is not a duplicate of How to *disable* automatic reboots in Windows 10? - that question and answer are only for Win10 Pro/Enterprise, not Win10 Home. I am even in communication with the author of that answer via his blog (who is refreshingly thorough with his testing and explanations but doesn't have access to Home), but the registry hack that is suggested there and elsewhere for Home users does not work - I have tested setting the value to 2, 3, and 5. Perhaps it used to work before the Anniversary Update, but...

9
  • It has been several days since we heard from you. Have you made any progress? – Run5k Nov 12 '16 at 3:19
  • Oh, sorry - I read the answer and the link, researched a couple related things, but then got interrupted before I could finish enough research to adequately reply. Then I forgot about it (my life is a bit hectic), and I didn't get a notification about your comment at all (I don't know why). I'll proceed now. – OsakaWebbie Dec 3 '16 at 12:02
  • Use WSUS you can then have complete control over the update process – Ramhound Dec 16 '16 at 12:57
  • 1
    Possible duplicate of How to *disable* automatic reboots in Windows 10? – Ramhound Dec 16 '16 at 14:49
  • WSUS doesn't work for Win10 Home. And your suggested duplicate is also not applicable to Home - see my question edit for details. – OsakaWebbie Dec 17 '16 at 4:47
1

I'm on Windows 10 Pro, and your description sounds very similar to how I use my computer. The only solution I could find uses Group Policy Editor, which is not available on Home. However, following instructions from this article may let you install it.

Provided that works, following the instructions in this image will do the following: When windows is ready to install updates, it will ask you permission to continue as well as give you a list of updates it's trying to install. You can usually allow it to continue if it's just something like Windows Defender updates, but if you see something like "Windows 10 cumulative..." then if you let it install, it will promptly start trying to restart. So hold off on allowing those until you're ready to restart.enter image description here

2
  • 1
    Interesting idea. I successfully followed the instructions to install gpedit.msc and configured Windows Update as pictured. Now we wait to see how Windows behaves the next time it has an update for me. I'll report back here. – OsakaWebbie Dec 17 '16 at 14:20
  • :D sounds good! Note: I think you have to restart for the changes to take place. What should happen next time updates are ready is instead of that action center notification saying "ready to restart" it should say "ready to install". – Blaine Dec 17 '16 at 14:46
1

I found this new setting in the Local Group Policy Editor (See screenshot) It Might fix the issue, but It remains to be verified.

New "Potential fix" in Local Group Policy Editor, Screenshot:

I'm changing this option from "Not configured" to "Enabled", I will try to verify whether or not this works. (Disclaimer: I'm using windows Pro and I do not know if the setting is there on other versions of windows)

6
  • Remove your own question from your answer. – Ramhound Dec 16 '16 at 12:56
  • ok, updated my "answer" with a screenshot showing a potential fix for the problem. :-) – Daniel Liljar Dec 16 '16 at 13:07
  • @DanielLiljar - Most users verify their answer will work before they submit it. How to disable automatic reboots in Windows 10? already has an answer to the question though. – Ramhound Dec 16 '16 at 14:49
  • And even a small amount of googling will reveal that the Group Policy Editor is not available in Win10 Home. – OsakaWebbie Dec 17 '16 at 4:49
  • @OsakaWebbie, it can be added to the Home Edition, just isn't included in the package. – fixer1234 Dec 17 '16 at 13:53
0

I think that you can leverage the Windows 10 Active Hours functionality to minimize the impact that updates (and their associated restarts) will have:

How to Set “Active Hours” So Windows 10 Won’t Restart at a Bad Time

Taking it a step further, if you really want full control over when Windows Updates reboot your machine and you are on Wi-Fi, you can potentially set your connection to be metered:

Windows 10 Active Hours: Never Restart Without Explicit Instruction

8
  • The Active Hours control won't help - I leave my PC on 24/7, normally with multiple projects in mid-progress. The 2nd link led to an article with 7 suggestions: #5 (regedit to allow local admin to change settings like the old days) best fits my situation, so I decided to try that. I did the regedit, but I can't find the settings screen shown in the first two screenshots on askvg.com/… - where is that? – OsakaWebbie Dec 3 '16 at 12:31
  • I believe that settings screen has been superseded by subsequent major updates to Windows 10. Please let us know if the registry modifications still work... it will be good information for future reference. – Run5k Dec 3 '16 at 14:33
  • I don't know if the registry mods work, because the pull-down doesn't exist that is supposed to be un-disabled by making that new registry entry with value 5. In the new layout of the settings screen I don't see anything resembling what I'm supposed to be able to do now. – OsakaWebbie Dec 3 '16 at 15:28
  • Needless to say, it is your call one way or another. I have servers that essentially need to be up 24/7/365, but I can safely say that I don't have any client workstations with such an extraordinary requirement. The Active Hours capability works rather well for most of us. In your scenario, I would probably perform a manual backup of the appropriate registry keys and give it a try. – Run5k Dec 3 '16 at 21:36
  • I didn't say that it has to be 24/7/365, and it isn't. It's just that I leave multiple windows open with partially-finished work and reference material for multiple days (sometimes weeks) at a time. I already did give the registry keys a try - I set the value to 5 to allow me to control the setting in the drop-down, but the drop-down seems to no longer exist. Okay, now I have changed the key value to 2, which is supposed to hardcode the setting to notify me before downloading updates. I won't know if it worked until the next time there is an update. – OsakaWebbie Dec 3 '16 at 23:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.