4

I have 3 different keyboard layouts set up on my laptop and use Ctrl+Shift+[1-3] key combination to switch between them. Like that:

Initial state - keys set

However, after locking and unlocking Windows (with a password), these hotkeys don't work anymore and key sequence is rolled back to (None):

After unlocking - (none)

Signing out from Windows or rebooting the laptop sets everything back to normal, until lock/unlock again.

I think this behaviour is related to the usage of the same hotkeys in File Explorer - to switch view (Extra large icons/Large icons/Medium icons accordingly). After the lock/unlock switch view starts working again.

Seems like File Explorer overrides language bar hotkeys after the unlocking.

How can I disable this functionality? Completely disabling Ctrl+Shift+number functionality in File Explorer will do, however I can't find anywhere on the internet how to do it.

Any ideas or help appreciated!

  • Have you recently updated to Version 1607 by chance? – Ramhound Oct 12 '16 at 15:18
  • It's newly installed Windows, version 1607, build 14393.222. Is it a know issue in 1607? – mcsdwarken Oct 12 '16 at 18:22
  • No; It is not a known issue. My thought process was that if you had updated from Version 1507, that in the past at least going from 10240 to Version 1507, the language packs and keyboard layouts have to be installed again (since they are obviously not compatiable with one another due to the interface changes). If you installed Version 1607 from an .ISO what I describe does not apply. – Ramhound Oct 12 '16 at 18:32
  • Indeed, I've installed language packs and keyboard layouts on 1607 already. I'm thinking now, maybe there is a way to set layout hot key "system wide", for all users at once. This may help, as on lock screen the assigned hot keys also don't work. – mcsdwarken Oct 13 '16 at 7:09
5

The picture is pretty self-explanatory. The idea is to propagate language settings of current user to the whole system. After copying settings the same hot keys are also available on the lock (welcome) screen (when typing a password).

After unlocking the hot keys are still set as they should.

enter image description here

  • Thanks ! Although I am a bit hesitant in stating the problem occurs only when locking/unlocking the screen, I checked it and it definitely reproduces in such scenario. And your solution fixes it ! I opened another question on the same topic and was guided to yours. Thanks for the fix! – Veverke Oct 13 '16 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.